summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorinfirit <[email protected]>2013-11-10 00:20:57 +0100
committerinfirit <[email protected]>2013-11-10 00:20:57 +0100
commit19cd8098df0317a85d332420f52bf168cc1cea11 (patch)
tree5d169a2c91b6ed3465700f23259252bf2fbacc61 /Makefile.am
parent40f399cd2ca2a74e3ce75785c9cde56ed27a9c79 (diff)
downloadmate-sensors-applet-19cd8098df0317a85d332420f52bf168cc1cea11.tar.bz2
mate-sensors-applet-19cd8098df0317a85d332420f52bf168cc1cea11.tar.xz
Add dist-hook for ChangeLog gen
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c94545d..f21a004 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -51,3 +51,17 @@ DISTCLEANFILES = intltool-extract \
intltool-update
DISTCHECK_CONFIGURE_FLAGS = --disable-scrollkeeper
+
+dist-hook:
+ @if test -d "$(srcdir)/.git"; \
+ then \
+ echo Creating ChangeLog && \
+ ( cd "$(top_srcdir)" && \
+ echo '# Generated by Makefile. Do not edit.'; echo; \
+ $(top_srcdir)/missing --run git log --stat ) > ChangeLog.tmp \
+ && mv -f ChangeLog.tmp $(distdir)/ChangeLog \
+ || ( rm -f ChangeLog.tmp ; \
+ echo Failed to generate ChangeLog >&2 ); \
+ else \
+ echo A git clone is required to generate a ChangeLog >&2; \
+ fi