summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorinfo-cppsp <[email protected]>2017-11-25 14:59:52 +0100
committerinfo-cppsp <[email protected]>2017-11-25 15:41:43 +0100
commit1f2046d8b7a2588b18e54db2153c850ff3328e2b (patch)
treed69c638a7fdb0f7409b925ff57a053a18f1a52ef /Makefile.am
parent6e568a41db4f833f59a08985576e1e1ceb3b4b93 (diff)
downloadmate-sensors-applet-1f2046d8b7a2588b18e54db2153c850ff3328e2b.tar.bz2
mate-sensors-applet-1f2046d8b7a2588b18e54db2153c850ff3328e2b.tar.xz
Fix project cleanup
Moved cleanup code from my autogenclean.sh to the main Makefile.am. Now, after ./autogen.sh, make, the 'make msa-clean' command removes ALL generated files.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 3776231..604865f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -49,6 +49,26 @@ DISTCLEANFILES = intltool-extract \
intltool-merge \
intltool-update
+MSACLEANFILES = aclocal.m4 \
+ compile \
+ config.* \
+ configure \
+ depcomp \
+ install-sh \
+ ltmain.sh \
+ missing \
+ omf.make \
+ xmldocs.make \
+ INSTALL \
+ $(top_srcdir)/sensors-applet/config.h*
+
+msa-clean: maintainer-clean
+ -test -z "$(MSACLEANFILES)" || rm -f $(MSACLEANFILES)
+ -rm -rf m4;
+ find . -name "Makefile.in" -exec rm \{\} \;
+
+.PHONY: msa-clean
+
# Build ChangeLog from GIT history
ChangeLog:
$(AM_V_GEN) if test -d $(top_srcdir)/.git; then \