summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorinfirit <[email protected]>2015-09-08 14:37:51 +0200
committerinfirit <[email protected]>2015-09-08 14:39:26 +0200
commit58c1d1c25d138c0b154e074c2c5b667551ac5239 (patch)
treefb004183c25fd747e069a34b4f639218099a1406 /Makefile.am
parent5cab0e83ac2f44fe78ba6ef1732a3286ec3f9476 (diff)
downloadmate-sensors-applet-58c1d1c25d138c0b154e074c2c5b667551ac5239.tar.bz2
mate-sensors-applet-58c1d1c25d138c0b154e074c2c5b667551ac5239.tar.xz
Rework gsettings schema building
* Bump intltool required version for gsettings support * Extract strings with intltool directly * Let autoconf generate the xml files
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 5 insertions, 11 deletions
diff --git a/Makefile.am b/Makefile.am
index 7949bdf..dd042b0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -26,29 +26,23 @@ org.mate.panel.applet.SensorsAppletFactory.service: $(service_in_files)
$< > $@
@INTLTOOL_XML_NOMERGE_RULE@
-gsettings_SCHEMAS = \
- org.mate.sensors-applet.gschema.xml \
- org.mate.sensors-applet.sensor.gschema.xml
+gsettingsschema_in_files = \
+ org.mate.sensors-applet.gschema.xml.in \
+ org.mate.sensors-applet.sensor.gschema.xml.in
-gsettings_SCHEMAS_in_in = $(gsettings_SCHEMAS:.xml=.xml.in.in)
+gsettings_SCHEMAS = $(gsettingsschema_in_files:.xml.in=.xml)
@GSETTINGS_RULES@
-%.gschema.xml.in: %.gschema.xml.in.in Makefile
- $(AM_V_GEN) $(SED) \
- -e 's^\@GETTEXT_PACKAGE\@^$(GETTEXT_PACKAGE)^g' \
- < $< > $@
-
CLEANFILES = $(applet_DATA) \
$(applet_DATA).in \
$(service_DATA) \
- $(gsettings_SCHEMAS_in) \
$(gsettings_SCHEMAS) \
*.gschema.valid
EXTRA_DIST = $(ui_DATA) \
$(applet_in_files).in \
$(service_in_files) \
- $(gsettings_SCHEMAS_in_in) \
+ $(gsettingsschema_in_files) \
autogen.sh
DISTCLEANFILES = intltool-extract \