summaryrefslogtreecommitdiff
path: root/plugins/hddtemp/Makefile.am
diff options
context:
space:
mode:
authorStefano Karapetsas <[email protected]>2011-11-21 23:44:15 +0100
committerStefano Karapetsas <[email protected]>2011-11-21 23:44:15 +0100
commit69ecddf1317e71f35b1c1de00392dc76f8f1701c (patch)
treeaba29401d8d4b88f14d67aac2b0e60980a78fa2e /plugins/hddtemp/Makefile.am
downloadmate-sensors-applet-69ecddf1317e71f35b1c1de00392dc76f8f1701c.tar.bz2
mate-sensors-applet-69ecddf1317e71f35b1c1de00392dc76f8f1701c.tar.xz
Initial release bases on sensors-applet
Diffstat (limited to 'plugins/hddtemp/Makefile.am')
-rw-r--r--plugins/hddtemp/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/plugins/hddtemp/Makefile.am b/plugins/hddtemp/Makefile.am
new file mode 100644
index 0000000..da45fa2
--- /dev/null
+++ b/plugins/hddtemp/Makefile.am
@@ -0,0 +1,21 @@
+# HDDTEMP plugin
+plugindir = $(libdir)/sensors-applet/plugins
+
+INCLUDES = -DGNOMELOCALEDIR=\""$(datadir)/locale/"\" \
+ -DG_LOG_DOMAIN=\""Sensors Applet"\" \
+ -DPIXMAPS_DIR=\""$(datadir)/pixmaps/$(PACKAGE)/"\" \
+ -DDATADIR=\""$(datadir)"\" \
+ -DLIBDIR=\""$(libdir)"\" \
+ -DSYSCONFDIR=\""$(sysconfdir)"\" \
+ -DPREFIX=\""$(prefix)"\" \
+ -I$(top_srcdir) \
+ $(GLIB_CFLAGS)
+
+plugin_LTLIBRARIES = libhddtemp.la
+
+libhddtemp_la_SOURCES = \
+ hddtemp-plugin.h \
+ hddtemp-plugin.c
+
+libhddtemp_la_LDFLAGS = $(PLUGIN_LIBTOOL_FLAGS) $(GLIB_LIBS)
+libhddtemp_la_LIBADD = $(top_builddir)/lib/libsensors-applet-plugin.la