summaryrefslogtreecommitdiff
path: root/plugins/netbsd/Makefile.am
diff options
context:
space:
mode:
authorJared McNeill <[email protected]>2018-05-20 22:28:17 -0300
committerraveit65 <[email protected]>2018-11-18 09:39:58 +0100
commit972866ede42e9e3c19241b88703cee6510bb2657 (patch)
treee319a25df36212d5fdc1918a5507ce94ba9ba6ab /plugins/netbsd/Makefile.am
parentff7769b5346ba40137570417fb29e7dd386b3150 (diff)
downloadmate-sensors-applet-972866ede42e9e3c19241b88703cee6510bb2657.tar.bz2
mate-sensors-applet-972866ede42e9e3c19241b88703cee6510bb2657.tar.xz
Add NetBSD support.
Diffstat (limited to 'plugins/netbsd/Makefile.am')
-rw-r--r--plugins/netbsd/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/plugins/netbsd/Makefile.am b/plugins/netbsd/Makefile.am
new file mode 100644
index 0000000..61e506f
--- /dev/null
+++ b/plugins/netbsd/Makefile.am
@@ -0,0 +1,23 @@
+# NetBSD plugin
+plugindir = $(libdir)/mate-sensors-applet/plugins
+
+AM_CPPFLAGS = -DMATELOCALEDIR=\""$(datadir)/locale/"\" \
+ -DG_LOG_DOMAIN=\""Sensors Applet"\" \
+ -DPIXMAPS_DIR=\""$(datadir)/pixmaps/$(PACKAGE)/"\" \
+ -DDATADIR=\""$(datadir)"\" \
+ -DLIBDIR=\""$(libdir)"\" \
+ -DSYSCONFDIR=\""$(sysconfdir)"\" \
+ -DPREFIX=\""$(prefix)"\" \
+ -I$(top_srcdir) \
+ $(GLIB_CFLAGS)
+
+
+plugin_LTLIBRARIES = libnetbsd.la
+
+libnetbsd_la_SOURCES = \
+ netbsd-plugin.h \
+ netbsd-plugin.c
+
+libnetbsd_la_LDFLAGS = $(PLUGIN_LIBTOOL_FLAGS) $(GLIB_LIBS) -lprop
+
+libnetbsd_la_LIBADD = $(top_builddir)/lib/libmate-sensors-applet-plugin.la