summaryrefslogtreecommitdiff
path: root/sensors-applet/Makefile.am
diff options
context:
space:
mode:
authorStefano Karapetsas <[email protected]>2012-12-16 23:31:49 +0100
committerStefano Karapetsas <[email protected]>2012-12-16 23:31:49 +0100
commitfbb7e89c4eab794cc9151e119c7ee94c9494dd7d (patch)
treec1ac3e7845d042dc74d59957e091fcf130764fec /sensors-applet/Makefile.am
parent5a584a07fe8ea0507d4bfe5c1b98f052f0001042 (diff)
downloadmate-sensors-applet-fbb7e89c4eab794cc9151e119c7ee94c9494dd7d.tar.bz2
mate-sensors-applet-fbb7e89c4eab794cc9151e119c7ee94c9494dd7d.tar.xz
migrate to GSettings and remove MateConf usage
migrate to DBUS and remove MateComponent usage remove libmate usage and use glib instead
Diffstat (limited to 'sensors-applet/Makefile.am')
-rw-r--r--sensors-applet/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/sensors-applet/Makefile.am b/sensors-applet/Makefile.am
index ce3cb01..7ea2099 100644
--- a/sensors-applet/Makefile.am
+++ b/sensors-applet/Makefile.am
@@ -1,9 +1,13 @@
## Process this file with automake to produce Makefile.in
+
+uidir = $(datadir)/mate-sensors-applet/ui
+
INCLUDES = -DMATELOCALEDIR=\""$(datadir)/locale/"\" \
-DG_LOG_DOMAIN=\""Sensors Applet"\" \
-DPIXMAPS_DIR=\""$(datadir)/pixmaps/$(PACKAGE)/"\" \
-DDATADIR=\""$(datadir)"\" \
-DLIBDIR=\""$(libdir)"\" \
+ -DUIDIR=\""$(pkgdatadir)/ui"\" \
-DSENSORS_APPLET_PLUGIN_DIR=\""$(libdir)/$(PACKAGE)/plugins/"\" \
-DSYSCONFDIR=\""$(sysconfdir)"\" \
-DPREFIX=\""$(prefix)"\" \
@@ -35,8 +39,8 @@ mate_sensors_applet_SOURCES = main.c \
sensors-applet-sensor.h \
sensors-applet-plugins.c \
sensors-applet-plugins.h \
- sensors-applet-mateconf.c \
- sensors-applet-mateconf.h \
+ sensors-applet-settings.c \
+ sensors-applet-settings.h \
$(libmatenotify_SRC)
# install headers for plugins to use