summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c94545d..befb0c5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,7 @@
SUBDIRS = sensors-applet lib plugins pixmaps po help
+ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
+
appletdir = $(datadir)/mate-panel/applets
applet_in_files = org.mate.applets.sensors-applet.mate-panel-applet.in
applet_DATA = $(applet_in_files:.mate-panel-applet.in=.mate-panel-applet)
@@ -27,6 +29,8 @@ org.mate.panel.applet.SensorsAppletFactory.service: $(service_in_files)
gsettings_SCHEMAS = \
org.mate.sensors-applet.gschema.xml \
org.mate.sensors-applet.sensor.gschema.xml
+
+gsettings_SCHEMAS_in_in = $(gsettings_SCHEMAS:.xml=.xml.in.in)
@GSETTINGS_RULES@
%.gschema.xml.in: %.gschema.xml.in.in Makefile
@@ -51,3 +55,17 @@ DISTCLEANFILES = intltool-extract \
intltool-update
DISTCHECK_CONFIGURE_FLAGS = --disable-scrollkeeper
+
+dist-hook:
+ @if test -d "$(srcdir)/.git"; \
+ then \
+ echo Creating ChangeLog && \
+ ( cd "$(top_srcdir)" && \
+ echo '# Generated by Makefile. Do not edit.'; echo; \
+ $(top_srcdir)/missing --run git log --stat ) > ChangeLog.tmp \
+ && mv -f ChangeLog.tmp $(distdir)/ChangeLog \
+ || ( rm -f ChangeLog.tmp ; \
+ echo Failed to generate ChangeLog >&2 ); \
+ else \
+ echo A git clone is required to generate a ChangeLog >&2; \
+ fi