summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 4 insertions, 12 deletions
diff --git a/Makefile.am b/Makefile.am
index f4c34b2..c595113 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,13 +2,16 @@ SUBDIRS = sensors-applet lib plugins pixmaps po help
ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
+APPLET_LOCATION = $(libdir)/mate-sensors-applet/libmate_sensors_applet.so
+
appletdir = $(datadir)/mate-panel/applets
applet_in_files = org.mate.applets.SensorsApplet.mate-panel-applet.desktop.in
applet_DATA = $(applet_in_files:.mate-panel-applet.desktop.in=.mate-panel-applet)
$(applet_in_files): $(applet_in_files).in Makefile
$(AM_V_GEN)sed \
- -e "s|\@LIBEXECDIR\@|$(libexecdir)|" \
+ -e "s|\@APPLET_LOCATION\@|$(APPLET_LOCATION)|" \
+ -e "s|\@VERSION\@|$(PACKAGE_VERSION)|" \
$< > $@
$(applet_DATA): $(applet_in_files) Makefile
@@ -17,15 +20,6 @@ $(applet_DATA): $(applet_in_files) Makefile
uidir = $(datadir)/mate-sensors-applet/ui
ui_DATA = SensorsApplet.xml
-servicedir = $(datadir)/dbus-1/services
-service_in_files = org.mate.panel.applet.SensorsAppletFactory.service.in
-service_DATA = $(service_in_files:.service.in=.service)
-
-org.mate.panel.applet.SensorsAppletFactory.service: $(service_in_files)
- $(AM_V_GEN)sed \
- -e "s|\@LIBEXECDIR\@|$(libexecdir)|" \
- $< > $@
-
gsettingsschema_in_files = \
org.mate.sensors-applet.gschema.xml.in \
org.mate.sensors-applet.sensor.gschema.xml.in
@@ -35,7 +29,6 @@ gsettings_SCHEMAS = $(gsettingsschema_in_files:.xml.in=.xml)
CLEANFILES = $(applet_DATA) \
$(applet_in_files) \
- $(service_DATA) \
$(gsettings_SCHEMAS) \
*.gschema.valid
@@ -45,7 +38,6 @@ DISTCHECK_CONFIGURE_FLAGS = \
EXTRA_DIST = $(ui_DATA) \
$(applet_in_files).in \
- $(service_in_files) \
$(gsettingsschema_in_files) \
autogen.sh