summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac29
1 files changed, 0 insertions, 29 deletions
diff --git a/configure.ac b/configure.ac
index 22c368b..e0f8b7d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -215,34 +215,6 @@ AM_CONDITIONAL(NVIDIA, test -n "$NVIDIA_LIBS")
AC_SUBST(NVIDIA_CFLAGS)
AC_SUBST(NVIDIA_LIBS)
-AC_ARG_WITH(aticonfig,
-[ --with-aticonfig[=PATH] use aticonfig plugin with optional binary provided
- by PATH], [
- if test "$withval" != "no" -a "$withval" != "yes"; then
- aticonfig_exe=$withval
- else
- aticonfig_exe=aticonfig
- fi
- with_aticonfig=$withval ], [
- aticonfig_exe=aticonfig
- with_aticonfig="check"
-])
-
-if test "x$with_aticonfig" = "xcheck"; then
- AC_CHECK_PROG(ATICONFIG_EXE, ["$aticonfig_exe"], yes, no)
- if test "x$ATICONFIG_EXE" = "xno"; then
- with_aticonfig="no"
- fi
-fi
-
-AM_CONDITIONAL(ATICONFIG, test "$with_aticonfig" != "no")
-if test "$with_aticonfig" = "no"; then
- echo "Disabling aticonfig support"
-else
- AC_DEFINE(HAVE_ATICONFIG,1,[using aticonfig])
- AC_DEFINE_UNQUOTED(ATICONFIG_EXE, ["$aticonfig_exe"], [aticonfig executable])
-fi
-
# enable netbsd plugin
AC_ARG_ENABLE(netbsd,
AS_HELP_STRING([--enable-netbsd],
@@ -293,7 +265,6 @@ AC_CONFIG_FILES([
plugins/mbmon/Makefile
plugins/netbsd/Makefile
plugins/nvidia/Makefile
- plugins/aticonfig/Makefile
plugins/omnibook/Makefile
plugins/pmu-sys/Makefile
plugins/smu-sys/Makefile