summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 02d4ff8..2ba67e5 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -8,12 +8,13 @@ AM_CPPFLAGS = -DMATELOCALEDIR=\""$(datadir)/locale/"\" \
-DSYSCONFDIR=\""$(sysconfdir)"\" \
-DPREFIX=\""$(prefix)"\" \
-I$(top_srcdir) \
- $(GLIB_CFLAGS)
+ $(GLIB_CFLAGS) \
+ $(WARN_CFLAGS)
LIBS = $(GLIB_LIBS)
# also build the libsensorsplugin library
lib_LTLIBRARIES = libmate-sensors-applet-plugin.la
-libmate_sensors_applet_plugin_la_SOURCES = sensors-applet-plugin.c
+libmate_sensors_applet_plugin_la_SOURCES = sensors-applet-plugin.c
libmate_sensors_applet_plugin_la_LDFLAGS = -export-dynamic