summaryrefslogtreecommitdiff
path: root/plugins/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/Makefile.am')
-rw-r--r--plugins/Makefile.am45
1 files changed, 45 insertions, 0 deletions
diff --git a/plugins/Makefile.am b/plugins/Makefile.am
new file mode 100644
index 0000000..ece115b
--- /dev/null
+++ b/plugins/Makefile.am
@@ -0,0 +1,45 @@
+DIST_SUBDIRS = \
+ acpi \
+ udisks \
+ eee \
+ hddtemp \
+ i2c-proc \
+ i2c-sys \
+ i8k \
+ ibm-acpi \
+ libsensors \
+ nvidia \
+ omnibook \
+ pmu-sys \
+ smu-sys \
+ sonypi \
+ aticonfig
+
+SUBDIRS = \
+ acpi \
+ eee \
+ hddtemp \
+ i8k \
+ ibm-acpi \
+ omnibook \
+ pmu-sys \
+ smu-sys \
+ sonypi
+
+if UDISKS
+SUBDIRS += udisks
+endif
+
+if LIBSENSORS
+SUBDIRS += libsensors
+else
+SUBDIRS += i2c-proc i2c-sys
+endif
+
+if NVIDIA
+SUBDIRS += nvidia
+endif
+
+if ATICONFIG
+SUBDIRS += aticonfig
+endif