summaryrefslogtreecommitdiff
path: root/plugins/eee/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/eee/Makefile.am')
-rw-r--r--plugins/eee/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/plugins/eee/Makefile.am b/plugins/eee/Makefile.am
new file mode 100644
index 0000000..0187c91
--- /dev/null
+++ b/plugins/eee/Makefile.am
@@ -0,0 +1,21 @@
+# ACPI plugin
+plugindir = $(libdir)/sensors-applet/plugins
+
+INCLUDES = -DGNOMELOCALEDIR=\""$(datadir)/locale/"\" \
+ -DG_LOG_DOMAIN=\""Sensors Applet"\" \
+ -DPIXMAPS_DIR=\""$(datadir)/pixmaps/$(PACKAGE)/"\" \
+ -DDATADIR=\""$(datadir)"\" \
+ -DLIBDIR=\""$(libdir)"\" \
+ -DSYSCONFDIR=\""$(sysconfdir)"\" \
+ -DPREFIX=\""$(prefix)"\" \
+ -I$(top_srcdir) \
+ $(GLIB_CFLAGS)
+
+plugin_LTLIBRARIES = libeee.la
+
+libeee_la_SOURCES = \
+ eee-plugin.h \
+ eee-plugin.c
+
+libeee_la_LDFLAGS = $(PLUGIN_LIBTOOL_FLAGS) $(GLIB_LIBS)
+libeee_la_LIBADD = $(top_builddir)/lib/libsensors-applet-plugin.la