summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMartin Wimpress <[email protected]>2017-01-18 16:31:24 +0000
committerGitHub <[email protected]>2017-01-18 16:31:24 +0000
commit2ce345fc5a2702e83a6d91035eb86426539c3a38 (patch)
treec9aa747d3385f2cb069a84c99a9ed357ebcb25ca /configure.ac
parent343219fd031b285483d7cbf98d22ac52095caa21 (diff)
parent3e8cab348e37b9879fa558e56e05069987c6c65a (diff)
downloadmate-session-manager-2ce345fc5a2702e83a6d91035eb86426539c3a38.tar.bz2
mate-session-manager-2ce345fc5a2702e83a6d91035eb86426539c3a38.tar.xz
Merge pull request #132 from mate-desktop/dont-listen
build: check stricter for presence of xtrans
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 11 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 02bb9be..7b705d3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -243,12 +243,18 @@ fi
AC_SUBST(EXECINFO_LIBS)
dnl ====================================================================
-dnl Check for newish X interface
+dnl Check for X transport interface - allows to disable ICE Transports
+dnl See also https://bugzilla.gnome.org/show_bug.cgi?id=725100
dnl ====================================================================
-oCFLAGS="$CFLAGS"
-CFLAGS="$CFLAGS $X_CFLAGS"
-AC_CHECK_HEADERS(X11/Xtrans/Xtrans.h)
-CFLAGS="$oCFLAGS"
+AC_ARG_WITH([xtrans],
+ [AS_HELP_STRING([--without-xtrans],
+ [Build without xtrans support (results in ICE listening on remote TCP ports)])],
+ [],
+ [with_xtrans=yes])
+AS_IF([test "$with_xtrans" != "no"],
+ [PKG_CHECK_MODULES(XTRANS, xtrans,
+ [AC_DEFINE(HAVE_XTRANS, 1, [Have the X Transport library])])])
+AC_SUBST(HAVE_XTRANS)
dnl ====================================================================
dnl Code for checking whether IPv6 is enabled on the system....