summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSander Sweers <[email protected]>2016-04-17 15:04:08 +0200
committermonsta <[email protected]>2017-03-05 14:12:12 +0300
commit9923739fe6f161a05078340593bf6a91db13d9be (patch)
tree04206ce1a4d88c8236229d2f1adfc325d8dcd641 /configure.ac
parent54d119718d8c2c109e089669aacdb66ffeb38a3e (diff)
downloadmate-session-manager-9923739fe6f161a05078340593bf6a91db13d9be.tar.bz2
mate-session-manager-9923739fe6f161a05078340593bf6a91db13d9be.tar.xz
Replace deprecated upower functions with ConsoleKit2 equivalents
This requires ConsoleKit2 version 0.9.2. + corrections for issues mentioned at https://github.com/mate-desktop/mate-session-manager/pull/133
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 0 insertions, 28 deletions
diff --git a/configure.ac b/configure.ac
index 4714e29..206feaf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -45,7 +45,6 @@ GLIB_REQUIRED=2.36.0
GIO_REQUIRED=2.25.0
GTK_REQUIRED=3.14.0
DBUS_GLIB_REQUIRED=0.76
-UPOWER_REQUIRED=0.9.0
dnl ====================================================================
dnl Dependency Checks
@@ -117,32 +116,6 @@ AM_CONDITIONAL(HAVE_SYSTEMD, test "x$use_systemd" = "xyes")
AC_SUBST(HAVE_SYSTEMD)
dnl ====================================================================
-dnl UPOWER
-dnl ====================================================================
-
-AC_ARG_ENABLE(upower,
- AS_HELP_STRING([--enable-upower],
- [Use upower to suspend/hibernate]),
- enable_upower=$enableval,
- enable_upower=no)
-if test "x$enable_upower" = "xyes"; then
- PKG_CHECK_MODULES([UPOWER], [upower-glib >= $UPOWER_REQUIRED], has_upower=yes, has_upower=no)
-
- if test "x$has_upower" = "xyes"; then
- AC_DEFINE(HAVE_UPOWER, 1, [upower support])
- AC_SUBST(UPOWER_CFLAGS)
- AC_SUBST(UPOWER_LIBS)
- fi
- PKG_CHECK_MODULES([UPOWER_HIBERNATE], [upower-glib < 0.99], has_upower_hibernate_suspend=yes, has_upower_hibernate_suspend=no)
- if test "x$has_upower_hibernate_suspend" = "xyes"; then
- AC_DEFINE(HAVE_UPOWER_HIBERNATE_SUSPEND, 1, [upower based support for hibernate and suspend (< 0.99)])
- fi
-
-fi
-AM_CONDITIONAL(HAVE_UPOWER, test "x$has_upower" = "xyes")
-AC_SUBST(HAVE_UPOWER)
-
-dnl ====================================================================
dnl Check for XSync extension
dnl ====================================================================
@@ -368,7 +341,6 @@ echo "
Default WM: ${with_default_wm}
Systemd support: ${use_systemd}
- Upower support: ${enable_upower}
IPv6 support: ${have_full_ipv6}
Backtrace support: ${have_backtrace}
XRender support: ${have_xrender}