summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStefano Karapetsas <[email protected]>2012-01-22 22:59:41 +0100
committerStefano Karapetsas <[email protected]>2012-01-22 22:59:41 +0100
commit8f91d9b2cefd226c60234a6122b624ba65e7b424 (patch)
tree7b9422f117477da0aa0145a1f14a02ae47493969 /configure.ac
parent5c00322b3ea38a54d06e6390711dd49c31b77040 (diff)
downloadmate-settings-daemon-8f91d9b2cefd226c60234a6122b624ba65e7b424.tar.bz2
mate-settings-daemon-8f91d9b2cefd226c60234a6122b624ba65e7b424.tar.xz
add support for gstreamer/alsa/oss instead of pulse for media-keys
https://bugzilla.gnome.org/show_bug.cgi?id=571145 patch stolen from debian: http://patch-tracker.debian.org/patch/series/view/gnome-settings-daemon/2.30.2-2+squeeze1/20_gstreamer.patch
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac44
1 files changed, 44 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4ec1b6d..b23d658 100644
--- a/configure.ac
+++ b/configure.ac
@@ -255,6 +255,49 @@ AC_SUBST(PULSE_LIBS)
dnl ==============================================
+dnl GStreamer section
+dnl ==============================================
+GST_MAJORMINOR=auto
+
+AC_ARG_ENABLE(gstreamer,
+AC_HELP_STRING([--enable-gstreamer],[use gstreamer if available (and optionally specify a version)]),
+[case "${enableval}" in
+ yes) ENABLE_GSTREAMER=yes ;;
+ 0.10) ENABLE_GSTREAMER=yes && GST_MAJORMINOR=0.10 ;;
+ no) ENABLE_GSTREAMER=no ;;
+ *) AC_MSG_ERROR([
+ *** Bad value ${enableval} for --enable-gstreamer
+ *** Please use one of the following:
+ *** --enable-gstreamer=0.10
+ ]) ;;
+esac],
+[ENABLE_GSTREAMER=yes]) dnl Default value
+
+have_gstreamer=no
+if test "x$ENABLE_GSTREAMER" = "xyes"; then
+ GST_REQS=0.10.1.2
+ PKGS="gstreamer-0.10 >= $GST_REQS gstreamer-plugins-base-0.10 >= $GST_REQS"
+
+ PKG_CHECK_MODULES(GST, $PKGS, have_gstreamer=yes,
+ AC_MSG_RESULT([no]))
+
+ if test "x$have_pulse" = "xtrue"; then
+ AC_MSG_ERROR([*** GStreamer & Pulseaudio both are selected ***])
+ fi
+
+ if test "x$have_gstreamer" = "xyes"; then
+ GST_LIBS="$GST_LIBS -lgstinterfaces-0.10 -lgstaudio-0.10"
+ AC_DEFINE(HAVE_GSTREAMER,1,[enable gstreamer])
+ fi
+else
+ AC_MSG_NOTICE([*** GStreamer support disabled ***])
+fi
+AM_CONDITIONAL(HAVE_GSTREAMER, test "x$have_gstreamer" = "xyes")
+AC_SUBST(GST_LIBS)
+AC_SUBST(GST_CFLAGS)
+
+
+dnl ==============================================
dnl smartcard section
dnl ==============================================
have_smartcard_support=false
@@ -480,6 +523,7 @@ echo "
PolicyKit support: ${HAVE_POLKIT}
Libmatenotify support: ${have_libmatenotify}
+ GStreamer support: ${have_gstreamer}
PulseAudio support: ${have_pulse}
Smartcard support: ${have_smartcard_support}
${NSS_DATABASE:+\