summaryrefslogtreecommitdiff
path: root/plugins/Makefile.am
diff options
context:
space:
mode:
authorPerberos <[email protected]>2011-12-01 23:53:21 -0300
committerPerberos <[email protected]>2011-12-01 23:53:21 -0300
commit505cabbd3036081f26586cabc64c26e7769c0ec9 (patch)
tree09e0498bf572128f5c9ab551531cb28d6d75e992 /plugins/Makefile.am
downloadmate-settings-daemon-505cabbd3036081f26586cabc64c26e7769c0ec9.tar.bz2
mate-settings-daemon-505cabbd3036081f26586cabc64c26e7769c0ec9.tar.xz
moving from https://github.com/perberos/mate-desktop-environment
Diffstat (limited to 'plugins/Makefile.am')
-rw-r--r--plugins/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/plugins/Makefile.am b/plugins/Makefile.am
new file mode 100644
index 0000000..f84cdf9
--- /dev/null
+++ b/plugins/Makefile.am
@@ -0,0 +1,31 @@
+NULL =
+
+enabled_plugins = \
+ a11y-keyboard \
+ background \
+ clipboard \
+ datetime \
+ dummy \
+ font \
+ housekeeping \
+ keybindings \
+ keyboard \
+ media-keys \
+ mouse \
+ sound \
+ typing-break \
+ xrandr \
+ xrdb \
+ xsettings \
+ $(NULL)
+
+disabled_plugins = $(NULL)
+
+if SMARTCARD_SUPPORT
+enabled_plugins += smartcard
+else
+disabled_plugins += smartcard
+endif
+
+SUBDIRS = common $(enabled_plugins)
+DIST_SUBDIRS = $(SUBDIRS) $(disabled_plugins)