summaryrefslogtreecommitdiff
path: root/plugins/background/Makefile.am
diff options
context:
space:
mode:
authorStefano Karapetsas <[email protected]>2012-12-15 12:33:17 -0800
committerStefano Karapetsas <[email protected]>2012-12-15 12:33:17 -0800
commit85c5ae14d75e3413b8f3f3aa38205ea852dcb20d (patch)
tree4750b8d23dfcb17aea6cbc62c7e1c788a6976a7b /plugins/background/Makefile.am
parent12dcf19aa5f51901053c273cd7f5c17ce85e909d (diff)
parentc6a6cbde72489a0055ba63341a153fe365058072 (diff)
downloadmate-settings-daemon-85c5ae14d75e3413b8f3f3aa38205ea852dcb20d.tar.bz2
mate-settings-daemon-85c5ae14d75e3413b8f3f3aa38205ea852dcb20d.tar.xz
Merge pull request #31 from jasmineaura/develop
background revised, various other fixes & improvements
Diffstat (limited to 'plugins/background/Makefile.am')
-rw-r--r--plugins/background/Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/plugins/background/Makefile.am b/plugins/background/Makefile.am
index a047573..01f0fc5 100644
--- a/plugins/background/Makefile.am
+++ b/plugins/background/Makefile.am
@@ -17,11 +17,13 @@ test_background_CPPFLAGS = \
test_background_CFLAGS = \
$(SETTINGS_PLUGIN_CFLAGS) \
+ $(MATE_DESKTOP_CFLAGS) \
$(AM_CFLAGS)
test_background_LDADD = \
$(top_builddir)/mate-settings-daemon/libmsd-profile.la \
$(SETTINGS_PLUGIN_LIBS) \
+ $(MATE_DESKTOP_LIBS) \
$(X11_LIBS) \
$(NULL)
@@ -30,8 +32,8 @@ plugin_LTLIBRARIES = \
$(NULL)
libbackground_la_SOURCES = \
- msd-background-plugin.h \
- msd-background-plugin.c \
+ msd-background-plugin.h \
+ msd-background-plugin.c \
msd-background-manager.h \
msd-background-manager.c \
$(NULL)
@@ -44,14 +46,16 @@ libbackground_la_CPPFLAGS = \
libbackground_la_CFLAGS = \
$(SETTINGS_PLUGIN_CFLAGS) \
+ $(MATE_DESKTOP_CFLAGS) \
$(AM_CFLAGS)
libbackground_la_LDFLAGS = \
- $(MSD_PLUGIN_LDFLAGS) \
+ $(MSD_PLUGIN_LDFLAGS) \
$(NULL)
libbackground_la_LIBADD = \
$(SETTINGS_PLUGIN_LIBS) \
+ $(MATE_DESKTOP_LIBS) \
$(NULL)
plugin_in_files = \