summaryrefslogtreecommitdiff
path: root/plugins/common/Makefile.am
diff options
context:
space:
mode:
authorPerberos <[email protected]>2011-12-01 23:53:21 -0300
committerPerberos <[email protected]>2011-12-01 23:53:21 -0300
commit505cabbd3036081f26586cabc64c26e7769c0ec9 (patch)
tree09e0498bf572128f5c9ab551531cb28d6d75e992 /plugins/common/Makefile.am
downloadmate-settings-daemon-505cabbd3036081f26586cabc64c26e7769c0ec9.tar.bz2
mate-settings-daemon-505cabbd3036081f26586cabc64c26e7769c0ec9.tar.xz
moving from https://github.com/perberos/mate-desktop-environment
Diffstat (limited to 'plugins/common/Makefile.am')
-rw-r--r--plugins/common/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/plugins/common/Makefile.am b/plugins/common/Makefile.am
new file mode 100644
index 0000000..447d02d
--- /dev/null
+++ b/plugins/common/Makefile.am
@@ -0,0 +1,23 @@
+
+noinst_LTLIBRARIES = libcommon.la
+
+libcommon_la_SOURCES = \
+ eggaccelerators.c \
+ eggaccelerators.h \
+ gsd-keygrab.c \
+ gsd-keygrab.h \
+ gsd-osd-window.c \
+ gsd-osd-window.h
+
+libcommon_la_CPPFLAGS = \
+ $(AM_CPPFLAGS)
+
+libcommon_la_CFLAGS = \
+ $(SETTINGS_PLUGIN_CFLAGS) \
+ $(AM_CFLAGS)
+
+libcommon_la_LDFLAGS = \
+ $(GSD_PLUGIN_LDFLAGS) $(X11_LIBS)
+
+libcommon_la_LIBADD = \
+ $(SETTINGS_PLUGIN_LIBS)