summaryrefslogtreecommitdiff
path: root/plugins/common/Makefile.am
diff options
context:
space:
mode:
authorinfirit <[email protected]>2014-12-13 15:30:40 +0100
committerinfirit <[email protected]>2014-12-13 18:32:16 +0100
commit420c17e9df0fe75f74b13f9d0caa91e764780c4b (patch)
treef2be9e365bcc05fac2923f23b04e0ea4891144b6 /plugins/common/Makefile.am
parent5561f9707602bca1e768a58f9c2ff30d70586ead (diff)
downloadmate-settings-daemon-420c17e9df0fe75f74b13f9d0caa91e764780c4b.tar.bz2
mate-settings-daemon-420c17e9df0fe75f74b13f9d0caa91e764780c4b.tar.xz
mouse: Move "has touchpad" function to common
So it can be reused. This also fixes a memory leak in the function. We were leaking the device list Taken from GSD commit: f6dcba4e954f3e910854f3c92fb69b157683267d From: Bastien Nocera <[email protected]>
Diffstat (limited to 'plugins/common/Makefile.am')
-rw-r--r--plugins/common/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/plugins/common/Makefile.am b/plugins/common/Makefile.am
index 3733a90..4cd30d8 100644
--- a/plugins/common/Makefile.am
+++ b/plugins/common/Makefile.am
@@ -6,6 +6,8 @@ libcommon_la_SOURCES = \
eggaccelerators.h \
msd-keygrab.c \
msd-keygrab.h \
+ msd-input-helper.c \
+ msd-input-helper.h \
msd-osd-window.c \
msd-osd-window.h
@@ -14,10 +16,12 @@ libcommon_la_CPPFLAGS = \
libcommon_la_CFLAGS = \
$(SETTINGS_PLUGIN_CFLAGS) \
+ $(XINPUT_CFLAGS) \
$(AM_CFLAGS)
libcommon_la_LDFLAGS = \
- $(MSD_PLUGIN_LDFLAGS) $(X11_LIBS)
+ $(MSD_PLUGIN_LDFLAGS) $(XINPUT_LIBS) $(X11_LIBS)
libcommon_la_LIBADD = \
- $(SETTINGS_PLUGIN_LIBS)
+ $(SETTINGS_PLUGIN_LIBS) \
+ $(XINPUT_LIBS)