summaryrefslogtreecommitdiff
path: root/plugins/keybindings/Makefile.am
diff options
context:
space:
mode:
authorStefano Karapetsas <[email protected]>2013-02-18 22:49:08 +0100
committerStefano Karapetsas <[email protected]>2013-02-18 22:49:08 +0100
commit6f12750fb05e6284b4356a6648a47ce202ff2d39 (patch)
tree2456bc6d385a50126518cd6ec11af188f400d4f9 /plugins/keybindings/Makefile.am
parentfc9ad81243511a82da3df74d03e21e366ce66416 (diff)
downloadmate-settings-daemon-6f12750fb05e6284b4356a6648a47ce202ff2d39.tar.bz2
mate-settings-daemon-6f12750fb05e6284b4356a6648a47ce202ff2d39.tar.xz
Re-added keybindings plugin, migrated to GSettings
Diffstat (limited to 'plugins/keybindings/Makefile.am')
-rw-r--r--plugins/keybindings/Makefile.am55
1 files changed, 55 insertions, 0 deletions
diff --git a/plugins/keybindings/Makefile.am b/plugins/keybindings/Makefile.am
new file mode 100644
index 0000000..4106e22
--- /dev/null
+++ b/plugins/keybindings/Makefile.am
@@ -0,0 +1,55 @@
+NULL =
+
+plugin_LTLIBRARIES = \
+ libkeybindings.la \
+ $(NULL)
+
+libkeybindings_la_SOURCES = \
+ dconf-util.h \
+ dconf-util.c \
+ msd-keybindings-plugin.h \
+ msd-keybindings-plugin.c \
+ msd-keybindings-manager.h \
+ msd-keybindings-manager.c \
+ $(NULL)
+
+libkeybindings_la_CPPFLAGS = \
+ -I$(top_srcdir)/mate-settings-daemon \
+ -I$(top_srcdir)/plugins/common \
+ -DMATE_SETTINGS_LOCALEDIR=\""$(datadir)/locale"\" \
+ $(AM_CPPFLAGS)
+
+libkeybindings_la_CFLAGS = \
+ $(SETTINGS_PLUGIN_CFLAGS) \
+ $(DCONF_CFLAGS) \
+ $(AM_CFLAGS)
+
+libkeybindings_la_LDFLAGS = \
+ $(MSD_PLUGIN_LDFLAGS) \
+ $(NULL)
+
+libkeybindings_la_LIBADD = \
+ $(top_builddir)/plugins/common/libcommon.la \
+ $(SETTINGS_PLUGIN_LIBS) \
+ $(DCONF_LIBS) \
+ $(NULL)
+
+plugin_in_files = \
+ keybindings.mate-settings-plugin.in \
+ $(NULL)
+
+plugin_DATA = $(plugin_in_files:.mate-settings-plugin.in=.mate-settings-plugin)
+
+EXTRA_DIST = \
+ $(plugin_in_files) \
+ $(NULL)
+
+CLEANFILES = \
+ $(plugin_DATA) \
+ $(NULL)
+
+DISTCLEANFILES = \
+ $(plugin_DATA) \
+ $(NULL)
+
+@MSD_INTLTOOL_PLUGIN_RULE@