summaryrefslogtreecommitdiff
path: root/plugins/smartcard/Makefile.am
diff options
context:
space:
mode:
authorWu Xiaotian <[email protected]>2019-08-29 16:19:54 +0800
committerRobert Antoni Buj Gelonch <[email protected]>2019-08-30 21:14:26 +0200
commit828be64b69942451e95b56a02dde1576af1bb856 (patch)
treed56c468286291666b5b687560d3eb4f5a51a5d30 /plugins/smartcard/Makefile.am
parentd2277c4a74e591fbff12c1d9a049ebd4f68221ea (diff)
downloadmate-settings-daemon-828be64b69942451e95b56a02dde1576af1bb856.tar.bz2
mate-settings-daemon-828be64b69942451e95b56a02dde1576af1bb856.tar.xz
switch to use gettext
Diffstat (limited to 'plugins/smartcard/Makefile.am')
-rw-r--r--plugins/smartcard/Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/plugins/smartcard/Makefile.am b/plugins/smartcard/Makefile.am
index 4e01be4..e9daad7 100644
--- a/plugins/smartcard/Makefile.am
+++ b/plugins/smartcard/Makefile.am
@@ -30,12 +30,13 @@ libsmartcard_la_LIBADD = \
$(SETTINGS_PLUGIN_LIBS) \
$(NSS_LIBS)
-@MSD_INTLTOOL_PLUGIN_RULE@
-
plugin_in_files = \
- smartcard.mate-settings-plugin.in
+ smartcard.mate-settings-plugin.desktop.in
+
+plugin_DATA = $(plugin_in_files:.mate-settings-plugin.desktop.in=.mate-settings-plugin)
-plugin_DATA = $(plugin_in_files:.mate-settings-plugin.in=.mate-settings-plugin)
+$(plugin_DATA): $(plugin_in_files)
+ $(AM_V_GEN) $(MSGFMT) --desktop --template $< -d $(top_srcdir)/po -o $@
EXTRA_DIST = \
$(plugin_in_files)