summaryrefslogtreecommitdiff
path: root/plugins/smartcard/Makefile.am
diff options
context:
space:
mode:
authorPerberos <[email protected]>2011-12-01 23:53:21 -0300
committerPerberos <[email protected]>2011-12-01 23:53:21 -0300
commit505cabbd3036081f26586cabc64c26e7769c0ec9 (patch)
tree09e0498bf572128f5c9ab551531cb28d6d75e992 /plugins/smartcard/Makefile.am
downloadmate-settings-daemon-505cabbd3036081f26586cabc64c26e7769c0ec9.tar.bz2
mate-settings-daemon-505cabbd3036081f26586cabc64c26e7769c0ec9.tar.xz
moving from https://github.com/perberos/mate-desktop-environment
Diffstat (limited to 'plugins/smartcard/Makefile.am')
-rw-r--r--plugins/smartcard/Makefile.am47
1 files changed, 47 insertions, 0 deletions
diff --git a/plugins/smartcard/Makefile.am b/plugins/smartcard/Makefile.am
new file mode 100644
index 0000000..a70e0a0
--- /dev/null
+++ b/plugins/smartcard/Makefile.am
@@ -0,0 +1,47 @@
+plugin_LTLIBRARIES = \
+ libsmartcard.la
+
+libsmartcard_la_SOURCES = \
+ gsd-smartcard-plugin.h \
+ gsd-smartcard-plugin.c \
+ gsd-smartcard.h \
+ gsd-smartcard.c \
+ gsd-smartcard-manager.h \
+ gsd-smartcard-manager.c
+
+libsmartcard_la_CPPFLAGS = \
+ -I$(top_srcdir)/mate-settings-daemon \
+ -DMATE_SETTINGS_LOCALEDIR=\""$(datadir)/locale"\" \
+ -DSYSCONFDIR=\""$(sysconfdir)"\" \
+ -DLIBDIR=\""$(libdir)"\" \
+ -DGSD_SMARTCARD_MANAGER_NSS_DB=\""$(NSS_DATABASE)"\" \
+ $(AM_CPPFLAGS)
+
+libsmartcard_la_CFLAGS = \
+ $(SETTINGS_PLUGIN_CFLAGS) \
+ $(MATE_CFLAGS) \
+ $(NSS_CFLAGS) \
+ $(AM_CFLAGS)
+
+libsmartcard_la_LDFLAGS = \
+ $(GSD_PLUGIN_LDFLAGS)
+
+libsmartcard_la_LIBADD = \
+ $(SETTINGS_PLUGIN_LIBS) \
+ $(NSS_LIBS)
+
+@GSD_INTLTOOL_PLUGIN_RULE@
+
+plugin_in_files = \
+ smartcard.mate-settings-plugin.in
+
+plugin_DATA = $(plugin_in_files:.mate-settings-plugin.in=.mate-settings-plugin)
+
+EXTRA_DIST = \
+ $(plugin_in_files)
+
+CLEANFILES = \
+ $(plugin_DATA)
+
+DISTCLEANFILES = \
+ $(plugin_DATA)