summaryrefslogtreecommitdiff
path: root/plugins/xrandr/Makefile.am
diff options
context:
space:
mode:
authorWu Xiaotian <[email protected]>2020-06-28 20:50:03 +0800
committerraveit65 <[email protected]>2023-10-07 19:54:38 +0200
commit672df567a7d2ae499c4b707c102263932a64db3e (patch)
treebd699a6b48cbbb0be574a072e5f14bbc6ca4a5ef /plugins/xrandr/Makefile.am
parent8a981c1ecbcc1bb9c6e0200d4f7fced7b8f59521 (diff)
downloadmate-settings-daemon-672df567a7d2ae499c4b707c102263932a64db3e.tar.bz2
mate-settings-daemon-672df567a7d2ae499c4b707c102263932a64db3e.tar.xz
xrandr: migrate from dbus-glib to GDBus
Diffstat (limited to 'plugins/xrandr/Makefile.am')
-rw-r--r--plugins/xrandr/Makefile.am11
1 files changed, 2 insertions, 9 deletions
diff --git a/plugins/xrandr/Makefile.am b/plugins/xrandr/Makefile.am
index f0a8815..ccf6f69 100644
--- a/plugins/xrandr/Makefile.am
+++ b/plugins/xrandr/Makefile.am
@@ -1,8 +1,6 @@
icondir = $(datadir)/icons/hicolor
context = apps
-BUILT_SOURCES = \
- msd-xrandr-manager-glue.h
ICON_FILES = \
msd-xrandr-16.png \
@@ -46,13 +44,8 @@ uninstall-local:
plugin_LTLIBRARIES = \
libxrandr.la
-msd-xrandr-manager-glue.h: msd-xrandr-manager.xml Makefile
- $(AM_V_GEN) dbus-binding-tool --prefix=msd_xrandr_manager --mode=glib-server $< > xgen-$(@F) \
- && ( cmp -s xgen-$(@F) $@ || cp xgen-$(@F) $@ ) \
- && rm -f xgen-$(@F)
libxrandr_la_SOURCES = \
- $(BUILT_SOURCES) \
msd-xrandr-plugin.h \
msd-xrandr-plugin.c \
msd-xrandr-manager.h \
@@ -84,8 +77,8 @@ plugin_in_files = \
plugin_DATA = $(plugin_in_files:.mate-settings-plugin.desktop.in=.mate-settings-plugin)
-EXTRA_DIST = $(plugin_in_files) $(ICON_FILES) msd-xrandr-manager.xml
-CLEANFILES = $(plugin_DATA) $(BUILT_SOURCES)
+EXTRA_DIST = $(plugin_in_files) $(ICON_FILES)
+CLEANFILES = $(plugin_DATA)
DISTCLEANFILES = $(plugin_DATA)
$(plugin_DATA): $(plugin_in_files)