summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 2d37078..2d42695 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -16,3 +16,17 @@ EXTRA_DIST = \
DISTCLEANFILES = \
$(NULL)
+
+dist-hook:
+ @if test -d "$(srcdir)/.git"; \
+ then \
+ echo Creating ChangeLog && \
+ (GIT_DIR=$(top_srcdir)/.git \
+ ./missing --run git log --stat -M -C --name-status --date=short --no-color) | \
+ fmt --split-only > ChangeLog.tmp \
+ && mv -f ChangeLog.tmp $(top_distdir)/ChangeLog \
+ || ( rm -f ChangeLog.tmp ; \
+ echo Failed to generate ChangeLog >&2 ); \
+ else \
+ echo A git clone is required to generate a ChangeLog >&2; \
+ fi