summaryrefslogtreecommitdiff
path: root/plugins/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/Makefile.am')
-rw-r--r--plugins/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/plugins/Makefile.am b/plugins/Makefile.am
new file mode 100644
index 0000000..f84cdf9
--- /dev/null
+++ b/plugins/Makefile.am
@@ -0,0 +1,31 @@
+NULL =
+
+enabled_plugins = \
+ a11y-keyboard \
+ background \
+ clipboard \
+ datetime \
+ dummy \
+ font \
+ housekeeping \
+ keybindings \
+ keyboard \
+ media-keys \
+ mouse \
+ sound \
+ typing-break \
+ xrandr \
+ xrdb \
+ xsettings \
+ $(NULL)
+
+disabled_plugins = $(NULL)
+
+if SMARTCARD_SUPPORT
+enabled_plugins += smartcard
+else
+disabled_plugins += smartcard
+endif
+
+SUBDIRS = common $(enabled_plugins)
+DIST_SUBDIRS = $(SUBDIRS) $(disabled_plugins)