summaryrefslogtreecommitdiff
path: root/plugins/background/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/background/Makefile.am')
-rw-r--r--plugins/background/Makefile.am75
1 files changed, 75 insertions, 0 deletions
diff --git a/plugins/background/Makefile.am b/plugins/background/Makefile.am
new file mode 100644
index 0000000..f773144
--- /dev/null
+++ b/plugins/background/Makefile.am
@@ -0,0 +1,75 @@
+NULL =
+
+noinst_PROGRAMS = \
+ test-background \
+ $(NULL)
+
+test_background_SOURCES = \
+ test-background.c \
+ gsd-background-manager.h \
+ gsd-background-manager.c \
+ $(NULL)
+
+test_background_CPPFLAGS = \
+ -I$(top_srcdir)/mate-settings-daemon \
+ -DMATE_SETTINGS_LOCALEDIR=\""$(datadir)/locale"\" \
+ $(AM_CPPFLAGS)
+
+test_background_CFLAGS = \
+ $(SETTINGS_PLUGIN_CFLAGS) \
+ $(AM_CFLAGS)
+
+test_background_LDADD = \
+ $(top_builddir)/mate-settings-daemon/libgsd-profile.la \
+ $(SETTINGS_PLUGIN_LIBS) \
+ $(X11_LIBS) \
+ $(NULL)
+
+plugin_LTLIBRARIES = \
+ libbackground.la \
+ $(NULL)
+
+libbackground_la_SOURCES = \
+ gsd-background-plugin.h \
+ gsd-background-plugin.c \
+ gsd-background-manager.h \
+ gsd-background-manager.c \
+ $(NULL)
+
+libbackground_la_CPPFLAGS = \
+ -I$(top_srcdir)/mate-settings-daemon \
+ -I$(top_srcdir)/plugins/background/libbackground \
+ -DMATE_SETTINGS_LOCALEDIR=\""$(datadir)/locale"\" \
+ $(AM_CPPFLAGS)
+
+libbackground_la_CFLAGS = \
+ $(SETTINGS_PLUGIN_CFLAGS) \
+ $(AM_CFLAGS)
+
+libbackground_la_LDFLAGS = \
+ $(GSD_PLUGIN_LDFLAGS) \
+ $(NULL)
+
+libbackground_la_LIBADD = \
+ $(SETTINGS_PLUGIN_LIBS) \
+ $(NULL)
+
+plugin_in_files = \
+ background.mate-settings-plugin.in \
+ $(NULL)
+
+plugin_DATA = $(plugin_in_files:.mate-settings-plugin.in=.mate-settings-plugin)
+
+EXTRA_DIST = \
+ $(plugin_in_files) \
+ $(NULL)
+
+CLEANFILES = \
+ $(plugin_DATA) \
+ $(NULL)
+
+DISTCLEANFILES = \
+ $(plugin_DATA) \
+ $(NULL)
+
+@GSD_INTLTOOL_PLUGIN_RULE@