summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBenoĆ®t Dejean <[email protected]>2015-08-02 06:37:21 +0200
committerMonsta <[email protected]>2015-10-15 14:45:35 +0300
commit56594f6f10ba04aa51af976bc8339ea9ae54ea21 (patch)
tree68cc51422ca9f3ede74773fc3c541b479bf2717e /configure.ac
parent744187cb9eeecdfa9ce1581aec2a6c8e2573fa09 (diff)
downloadmate-system-monitor-56594f6f10ba04aa51af976bc8339ea9ae54ea21.tar.bz2
mate-system-monitor-56594f6f10ba04aa51af976bc8339ea9ae54ea21.tar.xz
Add a smart CXXFLAGS / std=c++11 switch.mate-system-monitor-1.11.0
Code from glom and murrayc http://www.murrayc.com/permalink/2015/07/31/gtkmm-now-uses-c11/ .
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 4afb816..b7759db 100644
--- a/configure.ac
+++ b/configure.ac
@@ -20,6 +20,7 @@ AC_PROG_CC
AC_PROG_CXX
AC_LANG([C++])
AC_LANG_COMPILER_REQUIRE
+AX_CXX_COMPILE_STDCXX_11([],[mandatory])
PKG_PROG_PKG_CONFIG([0.19])
# Initialize libtool
@@ -103,7 +104,7 @@ if test "$GCC" = "yes" -a "$set_more_warnings" != "no"; then
-Wnested-externs -Wpointer-arith \
-Wcast-align -Wsign-compare \
$CFLAGS"
- CXXFLAGS="-Wall -std=c++98 $CXXFLAGS"
+ CXXFLAGS="-Wall $CXXFLAGS"
else
AC_MSG_RESULT(no)
fi