summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authormbkma <[email protected]>2021-04-24 22:21:20 +0200
committerraveit65 <[email protected]>2021-05-06 08:19:18 +0200
commitc12b68367de45f1f7c28a9517a3e610873d2b9e4 (patch)
treef3f8fe2a7a286977518d3cd160d311ffcea9303a /configure.ac
parentb3c7c7d45808586de317f5f8749cc2447c724ecb (diff)
downloadmate-system-monitor-c12b68367de45f1f7c28a9517a3e610873d2b9e4.tar.bz2
mate-system-monitor-c12b68367de45f1f7c28a9517a3e610873d2b9e4.tar.xz
Use GtkBuilder for preferences dialog
use g_settings_bind when possible use gresource for the ui file see https://gitlab.gnome.org/GNOME/gnome-system-monitor/-/commit/c816f2488c2debb8007ecc7487b177e72b7bf0c2
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 93fbff4..35a60f3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -79,6 +79,24 @@ AC_SUBST(GETTEXT_PACKAGE)
AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE",
[The gettext catalog name])
+# **********************
+# GLIB_COMPILE_RESOURCES
+# **********************
+AC_ARG_VAR([GLIB_COMPILE_RESOURCES],[glib-compile-resources bin])
+AC_PATH_PROG([GLIB_COMPILE_RESOURCES],[glib-compile-resources],[])
+if test -z "$GLIB_COMPILE_RESOURCES"; then
+ AC_MSG_ERROR([glib-compile-resources not found])
+fi
+
+# *******
+# XMLLINT
+# *******
+AC_ARG_VAR([XMLLINT],[xmllint bin])
+AC_PATH_PROG([XMLLINT],[xmllint],[])
+if test -z "$XMLLINT"; then
+ AC_MSG_ERROR([xmllint not found])
+fi
+
# Documentation
YELP_HELP_INIT