summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authormbkma <[email protected]>2021-04-24 19:45:10 +0200
committerraveit65 <[email protected]>2021-05-09 19:09:50 +0200
commit0b648d5782a9b6f050e6552bf62700495e161835 (patch)
treec9185497e98f3593f6243afb8466acffbd1e2de8 /src/Makefile.am
parentc12b68367de45f1f7c28a9517a3e610873d2b9e4 (diff)
downloadmate-system-monitor-0b648d5782a9b6f050e6552bf62700495e161835.tar.bz2
mate-system-monitor-0b648d5782a9b6f050e6552bf62700495e161835.tar.xz
port to GtkApplication
see https://gitlab.gnome.org/GNOME/gnome-system-monitor/-/commit/aa625d19e7b72587f70fb18dc3dcfcdba528533e
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am13
1 files changed, 3 insertions, 10 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index b001757..6811bba 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -37,7 +37,8 @@ mate_system_monitor_cpp_files = \
lsof.cpp \
selection.cpp \
settings-keys.cpp \
- iconthemewrapper.cpp
+ iconthemewrapper.cpp \
+ procman-app.cpp
mate_system_monitor_c_files = \
gsm_color_button.c
@@ -59,15 +60,7 @@ mate_system_monitor_CXXFLAGS = \
mate_system_monitor_CFLAGS = \
$(WARN_CFLAGS)
-mate_system_monitor_LDADD = @PROCMAN_LIBS@ @SYSTEMD_LIBS@ libbacon.la
-
-
-noinst_LTLIBRARIES = libbacon.la
-libbacon_la_SOURCES = \
- bacon-message-connection.c \
- bacon-message-connection.h
-libbacon_la_CFLAGS = \
- $(WARN_CFLAGS)
+mate_system_monitor_LDADD = @PROCMAN_LIBS@ @SYSTEMD_LIBS@
specdir = $(datadir)/procman