summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorrbuj <[email protected]>2019-02-22 12:02:30 +0100
committerraveit65 <[email protected]>2019-04-23 11:59:07 +0200
commitde1be0a956d49a82b67ec92741899fea7da60e3a (patch)
treeb73669266033a90ce39789f922ca90343138eaba /src/Makefile.am
parent0aa5954350341dca1d262915b956b3bc2ee7577d (diff)
downloadmate-terminal-de1be0a956d49a82b67ec92741899fea7da60e3a.tar.bz2
mate-terminal-de1be0a956d49a82b67ec92741899fea7da60e3a.tar.xz
Use gresources for about_DATA, uimanager_DATA & builder_DATA
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am37
1 files changed, 16 insertions, 21 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 8994e3a..938120c 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -9,6 +9,8 @@ bin_PROGRAMS = mate-terminal
BUILT_SOURCES = \
terminal-marshal.c \
terminal-marshal.h \
+ terminal-resources.c \
+ terminal-resources.h \
terminal-type-builtins.c \
terminal-type-builtins.h \
$(NULL)
@@ -64,6 +66,7 @@ nodist_mate_terminal_SOURCES= $(BUILT_SOURCES)
mate_terminal_CPPFLAGS = \
-DTERMINAL_COMPILATION \
+ -DTERMINAL_RESOURCES_PATH_PREFIX="\"/org/mate/terminal\"" \
-DTERM_DATADIR="\"$(datadir)\"" \
-DTERM_LOCALEDIR="\"$(datadir)/locale\"" \
-DTERM_PKGDATADIR="\"$(pkgdatadir)\"" \
@@ -136,32 +139,14 @@ terminal-marshal.c: $(srcdir)/terminal-marshal.list
&& mv terminal-marshal.c.tmp terminal-marshal.c ) \
|| ( rm -f terminal-marshal.c.tmp && exit 1 )
+terminal-resources.h terminal-resources.c: terminal.gresource.xml Makefile $(shell $(GLIB_COMPILE_RESOURCES) --generate-dependencies --sourcedir $(srcdir) $(srcdir)/terminal.gresource.xml)
+ $(AM_V_GEN) XMLLINT=$(XMLLINT) $(GLIB_COMPILE_RESOURCES) --target $@ --sourcedir $(srcdir) --generate --c-name terminal $<
+
gsettingsschema_in_files = org.mate.terminal.gschema.xml.in
gsettings_SCHEMAS = $(gsettingsschema_in_files:.xml.in=.xml)
.PRECIOUS: $(gsettings_SCHEMAS)
@INTLTOOL_XML_NOMERGE_RULE@
-aboutdir = $(pkgdatadir)
-about_DATA = \
- terminal.about \
- $(NULL)
-
-uimanagerdir = $(pkgdatadir)
-uimanager_DATA = \
- terminal.xml \
- $(NULL)
-
-builderdir = $(pkgdatadir)
-builder_DATA = \
- encodings-dialog.ui \
- find-dialog.ui \
- keybinding-editor.ui \
- profile-manager.ui \
- profile-new-dialog.ui \
- profile-preferences.ui \
- skey-challenge.ui \
- $(NULL)
-
CLEANFILES = \
stamp-terminal-type-builtins.h \
mate-terminal.schemas \
@@ -170,6 +155,16 @@ CLEANFILES = \
$(BUILT_SOURCES)
EXTRA_DIST = \
+ encodings-dialog.ui \
+ find-dialog.ui \
+ keybinding-editor.ui \
+ profile-manager.ui \
+ profile-new-dialog.ui \
+ profile-preferences.ui \
+ skey-challenge.ui \
+ terminal.about \
+ terminal.xml \
+ terminal.gresource.xml \
terminal-marshal.list \
terminal-type-builtins.c.template \
terminal-type-builtins.h.template \