summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authormonsta <[email protected]>2015-08-25 16:00:41 +0300
committerinfirit <[email protected]>2015-09-08 13:39:20 +0200
commit80c5e88588752d4a856a43fe292569afa6c1c31d (patch)
tree9008690c45e474f619279daca2a57596eebfc67f /src/Makefile.am
parent589ab9b7ce52f9b53dbea123c8fd2d9b3de1e53f (diff)
downloadmate-terminal-80c5e88588752d4a856a43fe292569afa6c1c31d.tar.bz2
mate-terminal-80c5e88588752d4a856a43fe292569afa6c1c31d.tar.xz
drop support for win32/osx
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am22
1 files changed, 5 insertions, 17 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 7f7477f..4d91119 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -89,30 +89,18 @@ mate_terminal_LDADD = \
skey/libskey.la \
$(TERM_LIBS)
-if WITH_SMCLIENT
mate_terminal_SOURCES += \
+ eggdesktopfile.c \
+ eggdesktopfile.h \
eggsmclient.c \
eggsmclient.h \
eggsmclient-private.h \
- $(NULL)
-mate_terminal_CFLAGS += $(SMCLIENT_CFLAGS)
-mate_terminal_LDADD += $(SMCLIENT_LIBS)
-
-if WITH_SMCLIENT_XSMP
-mate_terminal_SOURCES += \
- eggdesktopfile.c \
- eggdesktopfile.h \
eggsmclient-xsmp.c \
$(NULL)
+
+mate_terminal_CFLAGS += $(SMCLIENT_CFLAGS)
mate_terminal_CPPFLAGS += -DEGG_SM_CLIENT_BACKEND_XSMP
-endif
-if WITH_SMCLIENT_WIN32
-mate_terminal_SOURCES += eggsmclient-win32.c
-endif
-if WITH_SMCLIENT_QUARTZ
-mate_terminal_SOURCES += eggsmclient-osx.c
-endif
-endif
+mate_terminal_LDADD += $(SMCLIENT_LIBS)
TYPES_H_FILES = \
terminal-profile.h \