summaryrefslogtreecommitdiff
path: root/src/skey/Makefile.am
diff options
context:
space:
mode:
authorPerberos <[email protected]>2011-11-06 17:13:49 -0300
committerPerberos <[email protected]>2011-11-06 17:13:49 -0300
commit13e6e4ab1290cda9426eaedfeda70f7491b6b083 (patch)
tree2b9b2e1eac4cc6a161bea6f2197de4513ff1ddf7 /src/skey/Makefile.am
downloadmate-terminal-13e6e4ab1290cda9426eaedfeda70f7491b6b083.tar.bz2
mate-terminal-13e6e4ab1290cda9426eaedfeda70f7491b6b083.tar.xz
initial
Diffstat (limited to 'src/skey/Makefile.am')
-rw-r--r--src/skey/Makefile.am60
1 files changed, 60 insertions, 0 deletions
diff --git a/src/skey/Makefile.am b/src/skey/Makefile.am
new file mode 100644
index 0000000..0402507
--- /dev/null
+++ b/src/skey/Makefile.am
@@ -0,0 +1,60 @@
+NULL =
+
+noinst_LTLIBRARIES = libskey.la
+
+libskey_la_SOURCES = \
+ btoe.c \
+ btoe.h \
+ skey.h \
+ skey.c \
+ skeyutil.h\
+ skeyutil.c\
+ md4.c \
+ md4.h \
+ md5.c \
+ md5.h \
+ sha1.h \
+ sha1.c \
+ $(NULL)
+
+libskey_la_CPPFLAGS = \
+ -I$(srcdir)/.. \
+ -DG_DISABLE_SINGLE_INCLUDES \
+ $(DISABLE_DEPRECATED) \
+ $(AM_CPPFLAGS)
+
+libskey_la_CFLAGS = \
+ $(TERM_CFLAGS) \
+ $(WARN_CFLAGS) \
+ $(AM_CFLASG)
+
+libskey_la_LDFLAGS =
+
+libskey_la_LIBADD = \
+ $(TERM_LIBS)
+
+check_PROGRAMS = testskey
+
+testskey_SOURCES = \
+ test.c \
+ $(NULL)
+
+testskey_CPPFLAGS = \
+ -I$(srcdir)/.. \
+ $(DISABLE_DEPRECATED) \
+ $(AM_CPPFLAGS)
+
+testskey_CFLAGS = \
+ $(TERM_CFLAGS) \
+ $(WARN_CFLAGS) \
+ $(AM_CFLAGS)
+
+testskey_LDFLAGS =
+
+testskey_LDADD = \
+ libskey.la \
+ $(TERM_LIBS)
+
+TESTS = testskey
+
+-include $(top_srcdir)/git.mk