summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorraveit65 <[email protected]>2016-03-24 14:24:02 +0100
committerraveit65 <[email protected]>2016-03-24 14:25:10 +0100
commitbed08df0ccc0704cf72f2120e3bcb31e9c2a782f (patch)
tree468c48d62facf9b4ed352557ee07dbbdf8c38514 /configure.ac
parent4863bfb569df936e18a5e88a46ee9c2a106de5c1 (diff)
downloadmate-themes-bed08df0ccc0704cf72f2120e3bcb31e9c2a782f.tar.bz2
mate-themes-bed08df0ccc0704cf72f2120e3bcb31e9c2a782f.tar.xz
Gtk+-3.20 branch: make GreanLaguna optional (not default)
It isn't ported to gtk+-3.20 yet.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6cc5329f..338564d0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -41,6 +41,18 @@ AC_SUBST_FILE(media_stock_icons_rc)
AC_SUBST_FILE(capplet_stock_icons_rc)
AC_SUBST_FILE(marco_stock_icons_rc)
+dnl ***************************************************************************
+dnl *** Greenlaguna checks ***
+dnl ***************************************************************************
+AC_ARG_ENABLE(GreenLaguna,
+ [ --enable-GreenLaguna Install the GreenLaguna desktop theme.],
+ [enable_greenlaguna=$enableval], [enable_greenlaguna=no])
+
+AM_CONDITIONAL(BUILD_GREENLAGUNA, test "x$enable_greenlaguna" = "xyes")
+if test "$enable_greenlaguna" = yes; then
+ AC_DEFINE(BUILD_GREENLAGUNA, 1, [Install the GreenLaguna desktop theme.])
+fi
+
AC_CONFIG_FILES([
Makefile
common/Makefile
@@ -248,4 +260,8 @@ mate-themes-$VERSION:
Installation prefix: ${prefix}
+ Building extra themes: ${enable_greenlaguna}
+
+ configuration successfully :) now type make
+
"