summaryrefslogtreecommitdiff
path: root/desktop-themes/ContrastHigh/Makefile.am
diff options
context:
space:
mode:
authorraveit <[email protected]>2013-05-06 00:11:44 +0200
committerraveit <[email protected]>2013-05-06 00:11:44 +0200
commit931eacad9c4eb83d9059ad1bf38556cfd5e69431 (patch)
tree5a005fd315b1be799fced4380337322ef29cc070 /desktop-themes/ContrastHigh/Makefile.am
parentba1886dacf2bb54f34ca08c3dd5fad1c6eab2fcb (diff)
downloadmate-themes-931eacad9c4eb83d9059ad1bf38556cfd5e69431.tar.bz2
mate-themes-931eacad9c4eb83d9059ad1bf38556cfd5e69431.tar.xz
move ContrastHigh theme to desktop themes
Diffstat (limited to 'desktop-themes/ContrastHigh/Makefile.am')
-rw-r--r--desktop-themes/ContrastHigh/Makefile.am26
1 files changed, 20 insertions, 6 deletions
diff --git a/desktop-themes/ContrastHigh/Makefile.am b/desktop-themes/ContrastHigh/Makefile.am
index a2ac5dde..fb334d3c 100644
--- a/desktop-themes/ContrastHigh/Makefile.am
+++ b/desktop-themes/ContrastHigh/Makefile.am
@@ -1,11 +1,25 @@
THEME_NAME=ContrastHigh
-THEME_IN_FILES=index.theme.in
-
-@INTLTOOL_THEME_RULE@
-
+
themedir = $(datadir)/themes/$(THEME_NAME)
theme_DATA = index.theme
-DISTCLEANFILES=index.theme
-EXTRA_DIST=index.theme.in
+EXTRA_DIST = $(theme_DATA)
+
+SUBDIRS = \
+ gtk-3.0 \
+ gtk-2.0 \
+ metacity-1
+
+DIST_SUBDIRS = \
+ gtk-3.0 \
+ gtk-2.0 \
+ metacity-1
+
+CLEANFILES = index.theme
+
+index.theme: index.theme.in
+ $(AM_V_GEN)sed \
+ -e s!\@BACKGROUND_DIR\@!$(datadir)/backgrounds/mate/abstract! \
+ < $< > $@
+