summaryrefslogtreecommitdiff
path: root/desktop-themes/Green-Submarine/Makefile.am
diff options
context:
space:
mode:
authorrbuj <[email protected]>2021-02-09 14:46:52 +0100
committerraveit65 <[email protected]>2021-03-27 16:17:07 +0100
commit6127af25367a6c423826eea09be9307fcc08d615 (patch)
tree25fadd75dc7a204de17ae353c499b117a3c09b68 /desktop-themes/Green-Submarine/Makefile.am
parentff751f6c7707d0773f442d73dc38a3065c1b4e0b (diff)
downloadmate-themes-6127af25367a6c423826eea09be9307fcc08d615.tar.bz2
mate-themes-6127af25367a6c423826eea09be9307fcc08d615.tar.xz
build: allow users to disable gettext support (--disable-nls)
Diffstat (limited to 'desktop-themes/Green-Submarine/Makefile.am')
-rw-r--r--desktop-themes/Green-Submarine/Makefile.am19
1 files changed, 11 insertions, 8 deletions
diff --git a/desktop-themes/Green-Submarine/Makefile.am b/desktop-themes/Green-Submarine/Makefile.am
index 0cb9e35f..ab8e44ce 100644
--- a/desktop-themes/Green-Submarine/Makefile.am
+++ b/desktop-themes/Green-Submarine/Makefile.am
@@ -1,19 +1,22 @@
-THEME_NAME=Green-Submarine
-THEME_IN_FILES=index.theme.in
+THEME_NAME = Green-Submarine
themedir = $(datadir)/themes/$(THEME_NAME)
+theme_in_files = index.theme.in
+theme_DATA = $(theme_in_files:.theme.in=.theme)
-theme_DATA = index.theme
-
-$(theme_DATA): $(THEME_IN_FILES)
+%.theme: %.theme.in
+if USE_NLS
$(AM_V_GEN) $(MSGFMT) --desktop --template $< -d $(top_srcdir)/po -o $@
+else
+ $(AM_V_GEN) cp -f $< $@
+endif
SUBDIRS = \
cinnamon \
- emerald \
+ emerald \
gtk-2.0 \
gtk-3.0 \
metacity-1
-DISTCLEANFILES = index.theme
-EXTRA_DIST = index.theme.in
+CLEANFILES = index.theme
+EXTRA_DIST = $(theme_in_files)