summaryrefslogtreecommitdiff
path: root/desktop-themes/TraditionalOk/Makefile.am
diff options
context:
space:
mode:
authorraveit <[email protected]>2013-03-14 23:17:33 +0100
committerraveit <[email protected]>2013-03-14 23:17:33 +0100
commite39f02a2f2e04031822f9f13a80393362a8d61a3 (patch)
tree80cd8676fa2e3355c64a65c3f2002cf2c4e3d5a6 /desktop-themes/TraditionalOk/Makefile.am
parentb0c8a05db42235d28beca552b5b64e114a33c4c5 (diff)
downloadmate-themes-e39f02a2f2e04031822f9f13a80393362a8d61a3.tar.bz2
mate-themes-e39f02a2f2e04031822f9f13a80393362a8d61a3.tar.xz
update TraditionalOk to clearlooks-phenix development
Diffstat (limited to 'desktop-themes/TraditionalOk/Makefile.am')
-rw-r--r--desktop-themes/TraditionalOk/Makefile.am31
1 files changed, 26 insertions, 5 deletions
diff --git a/desktop-themes/TraditionalOk/Makefile.am b/desktop-themes/TraditionalOk/Makefile.am
index 93281ca7..31d141ff 100644
--- a/desktop-themes/TraditionalOk/Makefile.am
+++ b/desktop-themes/TraditionalOk/Makefile.am
@@ -1,11 +1,32 @@
THEME_NAME=TraditionalOk
-THEME_IN_FILES=index.theme.in
-%.theme: %.theme.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*.po) ; $(INTLTOOL_MERGE) $(top_srcdir)/po $< $@ -d -u -c $(top_builddir)/po/.intltool-merge-cache
-
themedir = $(datadir)/themes/$(THEME_NAME)
theme_DATA = index.theme
-DISTCLEANFILES=index.theme
-EXTRA_DIST=index.theme.in index.theme
+EXTRA_DIST = $(theme_DATA)
+
+SUBDIRS = \
+ doc \
+ gtk-2.0 \
+ gtk-3.0 \
+ metacity-1 \
+ openbox-3 \
+ wallpapers \
+ xfwm4
+
+DIST_SUBDIRS = \
+ doc \
+ gtk-2.0 \
+ gtk-3.0 \
+ metacity-1 \
+ openbox-3 \
+ wallpapers \
+ xfwm4
+
+CLEANFILES = index.theme
+
+index.theme: index.theme.in
+ $(AM_V_GEN)sed \
+ -e s!\@BACKGROUND_DIR\@!$(datadir)/pixmaps/backgrounds/mate/desktop! \
+ < $< > $@