summaryrefslogtreecommitdiff
path: root/desktop-themes/TraditionalOkTest/Makefile.am
diff options
context:
space:
mode:
authorStefano Karapetsas <[email protected]>2013-03-24 12:02:48 -0700
committerStefano Karapetsas <[email protected]>2013-03-24 12:02:48 -0700
commit6490dd6bf814ac5a078ce3a4f57bb7c28aa6dfa0 (patch)
tree63ce0c93ebe2e752411b945a345ae3506899bbc9 /desktop-themes/TraditionalOkTest/Makefile.am
parentd609f30420c313db3a65bbca38a5dfcecc3be9ea (diff)
parentdbc31b656fdb69ad5443c9a4750f8c659f40f00b (diff)
downloadmate-themes-6490dd6bf814ac5a078ce3a4f57bb7c28aa6dfa0.tar.bz2
mate-themes-6490dd6bf814ac5a078ce3a4f57bb7c28aa6dfa0.tar.xz
Merge pull request #28 from NiceandGently/master
add GTK3 support to TraditionalOKTest theme
Diffstat (limited to 'desktop-themes/TraditionalOkTest/Makefile.am')
-rw-r--r--desktop-themes/TraditionalOkTest/Makefile.am23
1 files changed, 18 insertions, 5 deletions
diff --git a/desktop-themes/TraditionalOkTest/Makefile.am b/desktop-themes/TraditionalOkTest/Makefile.am
index acd1e912..c55eef34 100644
--- a/desktop-themes/TraditionalOkTest/Makefile.am
+++ b/desktop-themes/TraditionalOkTest/Makefile.am
@@ -1,11 +1,24 @@
THEME_NAME=TraditionalOkTest
-THEME_IN_FILES=index.theme.in
-%.theme: %.theme.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*.po) ; $(INTLTOOL_MERGE) $(top_srcdir)/po $< $@ -d -u -c $(top_builddir)/po/.intltool-merge-cache
-
themedir = $(datadir)/themes/$(THEME_NAME)
theme_DATA = index.theme
-DISTCLEANFILES=index.theme
-EXTRA_DIST=index.theme.in index.theme
+EXTRA_DIST = $(theme_DATA)
+
+SUBDIRS = \
+ gtk-2.0 \
+ gtk-3.0 \
+ metacity-1
+
+DIST_SUBDIRS = \
+ gtk-2.0 \
+ gtk-3.0 \
+ metacity-1
+
+CLEANFILES = index.theme
+
+index.theme: index.theme.in
+ $(AM_V_GEN)sed \
+ -e s!\@BACKGROUND_DIR\@!$(datadir)/pixmaps/backgrounds/mate/desktop! \
+ < $< > $@