summaryrefslogtreecommitdiff
path: root/icon-themes/ContrastHigh/48x48/mimetypes/Makefile.am
diff options
context:
space:
mode:
authorraveit65 <[email protected]>2014-10-26 16:09:38 +0100
committerraveit65 <[email protected]>2014-10-26 16:17:21 +0100
commit0ce7f9e34014752b50afc6a9c7a77e952937f611 (patch)
tree6f69f37f3218184dc4a18d09288ed9462c4977ec /icon-themes/ContrastHigh/48x48/mimetypes/Makefile.am
parent6bb03b6b0dbff9513b88f3e566098906b22edf8f (diff)
downloadmate-themes-0ce7f9e34014752b50afc6a9c7a77e952937f611.tar.bz2
mate-themes-0ce7f9e34014752b50afc6a9c7a77e952937f611.tar.xz
move contrast icon theme to contrasthigh, where it belongs
Diffstat (limited to 'icon-themes/ContrastHigh/48x48/mimetypes/Makefile.am')
-rw-r--r--icon-themes/ContrastHigh/48x48/mimetypes/Makefile.am40
1 files changed, 40 insertions, 0 deletions
diff --git a/icon-themes/ContrastHigh/48x48/mimetypes/Makefile.am b/icon-themes/ContrastHigh/48x48/mimetypes/Makefile.am
new file mode 100644
index 00000000..19eb79af
--- /dev/null
+++ b/icon-themes/ContrastHigh/48x48/mimetypes/Makefile.am
@@ -0,0 +1,40 @@
+NULL=
+
+themedir = $(datadir)/icons/ContrastHigh
+size = 48x48
+context = mimetypes
+
+icondir = $(themedir)/$(size)/$(context)
+
+icon_DATA= \
+ application-x-executable.png \
+ audio-x-generic.png \
+ font-x-generic.png \
+ mate-mime-application-x-core-file.png \
+ image-x-generic.png \
+ package-x-generic.png \
+ text-x-generic.png \
+ text-x-preview.png \
+ video-x-generic.png \
+ x-office-address-book.png \
+ $(NULL)
+
+EXTRA_DIST= $(icon_DATA) \
+ symlinks.dat
+
+if LEGACY_ICON_MAPPING
+install-data-local: install-iconDATA
+ (cd $(DESTDIR)$(themedir)/$(size) && $(ICONMAP) -c $(context))
+endif
+
+install: install-am
+ $(SHELL) $(top_srcdir)/common/mkiconlinks.sh $(srcdir)/symlinks.dat $(DESTDIR)$(icondir)
+
+uninstall-symlinks:
+ list=`ls $(DESTDIR)$(icondir)`; for p in $$list; do \
+ if test -h $(DESTDIR)$(icondir)/$$p; then \
+ rm -f $(DESTDIR)$(icondir)/$$p; \
+ fi; \
+done
+
+uninstall-am: uninstall-iconDATA uninstall-symlinks