summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6cc5329f..338564d0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -41,6 +41,18 @@ AC_SUBST_FILE(media_stock_icons_rc)
AC_SUBST_FILE(capplet_stock_icons_rc)
AC_SUBST_FILE(marco_stock_icons_rc)
+dnl ***************************************************************************
+dnl *** Greenlaguna checks ***
+dnl ***************************************************************************
+AC_ARG_ENABLE(GreenLaguna,
+ [ --enable-GreenLaguna Install the GreenLaguna desktop theme.],
+ [enable_greenlaguna=$enableval], [enable_greenlaguna=no])
+
+AM_CONDITIONAL(BUILD_GREENLAGUNA, test "x$enable_greenlaguna" = "xyes")
+if test "$enable_greenlaguna" = yes; then
+ AC_DEFINE(BUILD_GREENLAGUNA, 1, [Install the GreenLaguna desktop theme.])
+fi
+
AC_CONFIG_FILES([
Makefile
common/Makefile
@@ -248,4 +260,8 @@ mate-themes-$VERSION:
Installation prefix: ${prefix}
+ Building extra themes: ${enable_greenlaguna}
+
+ configuration successfully :) now type make
+
"