summaryrefslogtreecommitdiff
path: root/desktop-themes/Blue-Submarine/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'desktop-themes/Blue-Submarine/Makefile.am')
-rw-r--r--desktop-themes/Blue-Submarine/Makefile.am14
1 files changed, 6 insertions, 8 deletions
diff --git a/desktop-themes/Blue-Submarine/Makefile.am b/desktop-themes/Blue-Submarine/Makefile.am
index 99e477f7..1a40b07c 100644
--- a/desktop-themes/Blue-Submarine/Makefile.am
+++ b/desktop-themes/Blue-Submarine/Makefile.am
@@ -4,7 +4,7 @@ themedir = $(datadir)/themes/$(THEME_NAME)
theme_DATA = index.theme
-EXTRA_DIST = $(theme_DATA)
+EXTRA_DIST = $(theme_DATA) index.theme.in
SUBDIRS = \
cinnamon \
@@ -13,11 +13,9 @@ SUBDIRS = \
gtk-3.0 \
metacity-1
-DIST_SUBDIRS = \
- cinnamon \
- emerald \
- gtk-2.0 \
- gtk-3.0 \
- metacity-1
-
CLEANFILES = index.theme
+
+index.theme: index.theme.in
+ $(AM_V_GEN)sed \
+ -e s!\@BACKGROUND_DIR\@!$(datadir)/backgrounds/mate/desktop! \
+ < $< > $@