summaryrefslogtreecommitdiff
path: root/desktop-themes/TraditionalOkTest/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'desktop-themes/TraditionalOkTest/Makefile.am')
-rw-r--r--desktop-themes/TraditionalOkTest/Makefile.am23
1 files changed, 18 insertions, 5 deletions
diff --git a/desktop-themes/TraditionalOkTest/Makefile.am b/desktop-themes/TraditionalOkTest/Makefile.am
index acd1e912..c55eef34 100644
--- a/desktop-themes/TraditionalOkTest/Makefile.am
+++ b/desktop-themes/TraditionalOkTest/Makefile.am
@@ -1,11 +1,24 @@
THEME_NAME=TraditionalOkTest
-THEME_IN_FILES=index.theme.in
-%.theme: %.theme.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*.po) ; $(INTLTOOL_MERGE) $(top_srcdir)/po $< $@ -d -u -c $(top_builddir)/po/.intltool-merge-cache
-
themedir = $(datadir)/themes/$(THEME_NAME)
theme_DATA = index.theme
-DISTCLEANFILES=index.theme
-EXTRA_DIST=index.theme.in index.theme
+EXTRA_DIST = $(theme_DATA)
+
+SUBDIRS = \
+ gtk-2.0 \
+ gtk-3.0 \
+ metacity-1
+
+DIST_SUBDIRS = \
+ gtk-2.0 \
+ gtk-3.0 \
+ metacity-1
+
+CLEANFILES = index.theme
+
+index.theme: index.theme.in
+ $(AM_V_GEN)sed \
+ -e s!\@BACKGROUND_DIR\@!$(datadir)/pixmaps/backgrounds/mate/desktop! \
+ < $< > $@