summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJasmine Hassan <[email protected]>2012-12-06 21:03:24 +0200
committerJasmine Hassan <[email protected]>2012-12-06 21:03:24 +0200
commitbe795227964c7b24027d525eaa634048e08c0df4 (patch)
treee6aedc37ee561c6b84a664c3b3f8903d38406cea /configure.in
parentbc18e5b352952b6365e5dff9de0f02f03f8efb13 (diff)
downloadmate-user-share-be795227964c7b24027d525eaa634048e08c0df4.tar.bz2
mate-user-share-be795227964c7b24027d525eaa634048e08c0df4.tar.xz
[all] Only add Bluetooth support to build if Bluetooth is available
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index e96149a..a0c57bf 100644
--- a/configure.in
+++ b/configure.in
@@ -56,10 +56,21 @@ if $have_dbus_1_1 ; then
AC_DEFINE(HAVE_DBUS_1_1, 1, [Set to true if we have D-BUS 1.1])
fi
-PKG_CHECK_MODULES(USER_SHARE, glib-2.0 >= 2.15.2 gio-2.0 >= 2.25.0 gdk-x11-2.0 gtk+-2.0 dbus-glib-1 libmatenotify libcanberra-gtk $DBUS_MODULES mate-bluetooth-1.0 >= 1.2.0)
+PKG_CHECK_MODULES(USER_SHARE, glib-2.0 >= 2.15.2 gio-2.0 >= 2.25.0 gdk-x11-2.0 gtk+-2.0 dbus-glib-1 libmatenotify libcanberra-gtk $DBUS_MODULES)
AC_SUBST(USER_SHARE_CFLAGS)
AC_SUBST(USER_SHARE_LIBS)
+PKG_CHECK_MODULES(BLUETOOTH, mate-bluetooth-1.0 >= 1.2.0,
+ have_bluetooth=true, have_bluetooth=false)
+AC_SUBST(BLUETOOTH_CFLAGS)
+AC_SUBST(BLUETOOTH_LIBS)
+if $have_bluetooth; then
+ AC_DEFINE(HAVE_BLUETOOTH, 1, [Set to true if mate-bluetooth support is available])
+else
+ AC_MSG_WARN([Bluetooth support is disabled.])
+fi
+AM_CONDITIONAL(USE_BLUETOOTH, [test "$have_bluetooth" = "true"])
+
PKG_CHECK_MODULES(USER_SHARE_CONFIG, glib-2.0 >= 2.15.2 gio-2.0 >= 2.25.0 gtk+-2.0 >= 2.12.0 unique-1.0)
AC_SUBST(USER_SHARE_CONFIG_CFLAGS)
AC_SUBST(USER_SHARE_CONFIG_LIBS)