summaryrefslogtreecommitdiff
path: root/data/icons/Makefile.am
diff options
context:
space:
mode:
authorSteve Zesch <[email protected]>2012-05-14 13:35:03 -0400
committerSteve Zesch <[email protected]>2012-05-14 13:35:03 -0400
commit130eaa7d69ed4803041774442ccb6a9d7ea1ec4c (patch)
treef7339140f1c496a53e1c43ae9f3742235f5ae1b9 /data/icons/Makefile.am
parentb42609046ef05f8d8be4b08ac50ea10a3c6dfe71 (diff)
downloadmate-user-share-130eaa7d69ed4803041774442ccb6a9d7ea1ec4c.tar.bz2
mate-user-share-130eaa7d69ed4803041774442ccb6a9d7ea1ec4c.tar.xz
Forked gnome-user-share. Work in progress.
Diffstat (limited to 'data/icons/Makefile.am')
-rw-r--r--data/icons/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/data/icons/Makefile.am b/data/icons/Makefile.am
new file mode 100644
index 0000000..26a633d
--- /dev/null
+++ b/data/icons/Makefile.am
@@ -0,0 +1,17 @@
+SUBDIRS = 16x16 22x22 32x32 48x48
+
+gtk_update_icon_cache = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor
+
+install-data-hook: update-icon-cache
+uninstall-hook: update-icon-cache
+update-icon-cache:
+ @-if test -z "$(DESTDIR)"; then \
+ echo "Updating Gtk icon cache."; \
+ $(gtk_update_icon_cache); \
+ else \
+ echo "*** Icon cache not updated. After (un)install, run this:"; \
+ echo "*** $(gtk_update_icon_cache)"; \
+ fi
+
+
+-include $(top_srcdir)/git.mk