summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..982c793
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,26 @@
+SUBDIRS = data po src help
+
+EXTRA_DIST = \
+ intltool-extract.in \
+ intltool-merge.in \
+ intltool-update.in
+
+DISTCLEANFILES = \
+ intltool-extract \
+ intltool-merge \
+ intltool-update
+
+DISTCHECK_CONFIGURE_FLAGS = --disable-schemas-install --with-nautilusdir='$${libdir}/caja/extensions-2.0-distcheck'
+
+# Build ChangeLog from GIT history
+ChangeLog:
+ @if test -f $(top_srcdir)/.git/HEAD; then \
+ git log --stat --after="Thu Jun 11 22:19:01 2009" > $@; \
+ fi
+
+dist: ChangeLog
+
+.PHONY: ChangeLog
+
+
+-include $(top_srcdir)/git.mk