summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 7 insertions, 9 deletions
diff --git a/configure.in b/configure.in
index fddebf7..c45422a 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
-AC_INIT(mate-user-share, 1.4.1)
+AC_INIT(mate-user-share, 1.5.0)
AM_INIT_AUTOMAKE([1.9 dist-bzip2 no-dist-gzip check-news])
AM_CONFIG_HEADER(config.h)
@@ -56,11 +56,11 @@ if $have_dbus_1_1 ; then
AC_DEFINE(HAVE_DBUS_1_1, 1, [Set to true if we have D-BUS 1.1])
fi
-PKG_CHECK_MODULES(USER_SHARE, glib-2.0 >= 2.15.2 gio-2.0 gdk-x11-2.0 gtk+-2.0 mateconf-2.0 dbus-glib-1 libmatenotify libcanberra-gtk $DBUS_MODULES mate-bluetooth-1.0 >= 1.2.0)
+PKG_CHECK_MODULES(USER_SHARE, glib-2.0 >= 2.15.2 gio-2.0 >= 2.25.0 gdk-x11-2.0 gtk+-2.0 dbus-glib-1 libmatenotify libcanberra-gtk $DBUS_MODULES mate-bluetooth-1.0 >= 1.2.0)
AC_SUBST(USER_SHARE_CFLAGS)
AC_SUBST(USER_SHARE_LIBS)
-PKG_CHECK_MODULES(USER_SHARE_CONFIG, glib-2.0 >= 2.15.2 gtk+-2.0 >= 2.12.0 mateconf-2.0 unique-1.0)
+PKG_CHECK_MODULES(USER_SHARE_CONFIG, glib-2.0 >= 2.15.2 gio-2.0 >= 2.25.0 gtk+-2.0 >= 2.12.0 unique-1.0)
AC_SUBST(USER_SHARE_CONFIG_CFLAGS)
AC_SUBST(USER_SHARE_CONFIG_LIBS)
@@ -81,13 +81,11 @@ fi
AC_PATH_PROG([GLIB_GENMARSHAL],[glib-genmarshal])
-AC_PATH_PROG(MATECONFTOOL, mateconftool-2, no)
+dnl
+dnl Enable gsettigns schema macros
+dnl
-if test x"$MATECONFTOOL" = xno; then
- AC_MSG_ERROR([mateconftool-2 executable not found in your path - should be installed with GConf])
-fi
-
-AM_MATECONF_SOURCE_2
+GLIB_GSETTINGS
dnl where to install the mate-user-share binary
if test "x$prefix" = "xNONE"; then