summaryrefslogtreecommitdiff
path: root/baobab/data/Makefile.am
diff options
context:
space:
mode:
authorrbuj <[email protected]>2021-01-27 18:03:29 +0100
committerraveit65 <[email protected]>2021-02-08 20:39:25 +0100
commit5af31646583faedf3d16746f19e4d7d679852ac4 (patch)
treefd63bcbdb1a45bc8dbe08ce4c772eaea0c6e49f8 /baobab/data/Makefile.am
parent1397f530214fe111405d98687d4b50b4ad23da45 (diff)
downloadmate-utils-5af31646583faedf3d16746f19e4d7d679852ac4.tar.bz2
mate-utils-5af31646583faedf3d16746f19e4d7d679852ac4.tar.xz
build: allow users to disable gettext support (--disable-nls)
Diffstat (limited to 'baobab/data/Makefile.am')
-rw-r--r--baobab/data/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/baobab/data/Makefile.am b/baobab/data/Makefile.am
index a5835007..9794bdcc 100644
--- a/baobab/data/Makefile.am
+++ b/baobab/data/Makefile.am
@@ -21,13 +21,22 @@ $(baobabapp_in_files): $(baobabapp_in_files:.desktop.in=.desktop.in.in)
sed -e "s|\@VERSION\@|@VERSION@|" $< > $@
$(baobabapp_DATA): $(baobabapp_in_files)
+if USE_NLS
$(AM_V_GEN) $(MSGFMT) --desktop --template $< -d $(top_srcdir)/po -o $@
+else
+ $(AM_V_GEN) cp $< $@
+endif
appdatadir = $(datadir)/metainfo
appdata_in_files = mate-disk-usage-analyzer.appdata.xml.in
appdata_DATA = $(appdata_in_files:.xml.in=.xml)
+
$(appdata_DATA): $(appdata_in_files)
+if USE_NLS
$(AM_V_GEN) $(MSGFMT) --xml --template $< -d $(top_srcdir)/po -o $@
+else
+ $(AM_V_GEN) cp $< $@
+endif
gsettings_SCHEMAS = org.mate.disk-usage-analyzer.gschema.xml
@GSETTINGS_RULES@