summaryrefslogtreecommitdiff
path: root/baobab/pixmaps/24x24/Makefile.am
diff options
context:
space:
mode:
authorrbuj <[email protected]>2019-03-16 18:22:58 +0100
committerraveit65 <[email protected]>2019-03-25 13:15:05 +0100
commit14cd43685163f3ad3e9a79a5b2cb05e7fb420f91 (patch)
tree55e39e057bd1b686eb020bdf9ff6cb693aac525b /baobab/pixmaps/24x24/Makefile.am
parente46d962c7d048121bf845bbc2eaaac5849d2aefc (diff)
downloadmate-utils-14cd43685163f3ad3e9a79a5b2cb05e7fb420f91.tar.bz2
mate-utils-14cd43685163f3ad3e9a79a5b2cb05e7fb420f91.tar.xz
GEN png icons from svg files
PNG icons are created if they are not present in icon folder. To remove png icons: make -C baobab/pixmaps clean-png-icons make -C logview/data/icons clean-png-icons To build png icons: make -C baobab/pixmaps build-png-icons make -C logview/data/icons build-png-icons This removes baobab/pixmaps/shot.png file, use applets-screenshooter named icon (used in mate-screenshot).
Diffstat (limited to 'baobab/pixmaps/24x24/Makefile.am')
-rw-r--r--baobab/pixmaps/24x24/Makefile.am29
1 files changed, 0 insertions, 29 deletions
diff --git a/baobab/pixmaps/24x24/Makefile.am b/baobab/pixmaps/24x24/Makefile.am
deleted file mode 100644
index 7edb810a..00000000
--- a/baobab/pixmaps/24x24/Makefile.am
+++ /dev/null
@@ -1,29 +0,0 @@
-NULL =
-
-size = 24x24
-
-iconsdir = $(datadir)/icons/hicolor/$(size)/apps
-
-icons_DATA = \
- mate-disk-usage-analyzer.png \
- $(NULL)
-
-icons_SOURCE = \
- $(NULL)
-
-EXTRA_DIST = \
- $(icons_DATA) \
- $(icons_SOURCE)
-
-gtk_update_icon_cache = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor
-
-install-data-hook: update-icon-cache
-uninstall-hook: update-icon-cache
-update-icon-cache:
- @-if test -z "$(DESTDIR)"; then \
- echo "Updating Gtk icon cache."; \
- $(gtk_update_icon_cache); \
- else \
- echo "*** Icon cache not updated. After (un)install, run this:"; \
- echo "*** $(gtk_update_icon_cache)"; \
- fi