summaryrefslogtreecommitdiff
path: root/mate-dictionary/data/Makefile.am
diff options
context:
space:
mode:
authorBrent Hull <[email protected]>2013-01-25 02:39:32 -0500
committerBrent Hull <[email protected]>2013-01-25 02:39:32 -0500
commit1acc3477eeb71505d68b66ac7aa4a796f86fe69c (patch)
treec4c7950e24d8393980b41c6bd649c450e628a6f2 /mate-dictionary/data/Makefile.am
parent3f783bbd74e1f94e97f91829480b32b05b6480c8 (diff)
downloadmate-utils-1acc3477eeb71505d68b66ac7aa4a796f86fe69c.tar.bz2
mate-utils-1acc3477eeb71505d68b66ac7aa4a796f86fe69c.tar.xz
Port mate-dictionary (and applet) to Gsettings (main program based on GNOME patch)
Diffstat (limited to 'mate-dictionary/data/Makefile.am')
-rw-r--r--mate-dictionary/data/Makefile.am39
1 files changed, 17 insertions, 22 deletions
diff --git a/mate-dictionary/data/Makefile.am b/mate-dictionary/data/Makefile.am
index 2e38a96c..55f553df 100644
--- a/mate-dictionary/data/Makefile.am
+++ b/mate-dictionary/data/Makefile.am
@@ -7,7 +7,7 @@ gdictapp_in_files = mate-dictionary.desktop.in
gdictapp_DATA = $(gdictapp_in_files:.desktop.in=.desktop)
$(gdictapp_in_files): $(gdictapp_in_files:.desktop.in=.desktop.in.in)
- @sed -e "s|\@VERSION\@|@VERSION@|" $< > $@
+ $(AM_V_GEN)sed -e "s|\@VERSION\@|@VERSION@|" $< > $@
@INTLTOOL_DESKTOP_RULE@
@@ -22,8 +22,10 @@ dictsource_DATA = $(dictsource_in_files:.desktop.in=.desktop)
@INTLTOOL_DESKTOP_RULE@
builderdir = $(datadir)/mate-dictionary
-builder_DATA = mate-dictionary-preferences.ui \
- mate-dictionary-source.ui
+builder_DATA = \
+ mate-dictionary-preferences.ui \
+ mate-dictionary-source.ui \
+ $(NULL)
uidir = $(datadir)/mate-dictionary
ui_DATA = mate-dictionary-ui.xml
@@ -39,27 +41,29 @@ server_in_files = MATE_DictionaryApplet.server.in
server_DATA = $(server_in_files:.server.in=.server)
$(server_in_files): $(server_in_files:.server.in=.server.in.in)
- @sed \
- -e "s|\@VERSION\@|@VERSION@|" \
- -e "s|\@LIBEXECDIR\@|$(libexecdir)|" \
+ $(AM_V_GEN)sed \
+ -e "s|\@VERSION\@|@VERSION@|" \
+ -e "s|\@LIBEXECDIR\@|$(libexecdir)|" \
$< > $@
-
@INTLTOOL_SERVER_RULE@
endif # BUILD_GDICT_APPLET
-schemadir = $(MATECONF_SCHEMA_FILE_DIR)
-schemas_in_file = mate-dictionary.schemas.in
-schema_DATA = $(schemas_in_file:.schemas.in=.schemas)
-@INTLTOOL_SCHEMAS_RULE@
+gsettingsschema_in_files = org.mate.dictionary.gschema.xml.in
+gsettings_SCHEMAS = $(gsettingsschema_in_files:.xml.in=.xml)
+@INTLTOOL_XML_NOMERGE_RULE@
+@GSETTINGS_RULES@
+
+convertdir = $(datadir)/MateConf/gsettings
+convert_DATA = mate-dictionary.convert
EXTRA_DIST = \
MATE_DictionaryApplet.server.in.in \
mate-dictionary.desktop.in.in \
$(dictsource_in_files) \
$(man_MANS) \
- $(schemas_in_file) \
+ $(gsettingsschema_in_files) \
$(builder_DATA) \
$(ui_DATA) \
$(appletui_DATA) \
@@ -71,14 +75,5 @@ CLEANFILES = \
$(server_DATA) \
$(gdictapp_in_files) \
$(gdictapp_DATA) \
- $(schema_DATA) \
+ $(gsettings_SCHEMAS) \
$(NULL)
-
-if MATECONF_SCHEMAS_INSTALL
-install-data-local:
- if test -z "$(DESTDIR)" ; then \
- MATECONF_CONFIG_SOURCE=$(MATECONF_SCHEMA_CONFIG_SOURCE) $(MATECONFTOOL) --makefile-install-rule $(schema_DATA) ; \
- fi
-else
-install-data-local:
-endif