summaryrefslogtreecommitdiff
path: root/mate-dictionary/data/Makefile.am
diff options
context:
space:
mode:
authorWu Xiaotian <[email protected]>2019-12-25 10:30:02 +0800
committerraveit65 <[email protected]>2019-12-28 11:52:39 +0100
commit6364c09edc1f888d5596bb93086189f431776874 (patch)
treea14029472830f23818df35bca4140f17abcce155 /mate-dictionary/data/Makefile.am
parent0568d8eeb506deff95f100b4ba55508b74e44542 (diff)
downloadmate-utils-6364c09edc1f888d5596bb93086189f431776874.tar.bz2
mate-utils-6364c09edc1f888d5596bb93086189f431776874.tar.xz
migrate from intltools to gettext
Diffstat (limited to 'mate-dictionary/data/Makefile.am')
-rw-r--r--mate-dictionary/data/Makefile.am21
1 files changed, 12 insertions, 9 deletions
diff --git a/mate-dictionary/data/Makefile.am b/mate-dictionary/data/Makefile.am
index 8db2aa70..f7dee120 100644
--- a/mate-dictionary/data/Makefile.am
+++ b/mate-dictionary/data/Makefile.am
@@ -9,8 +9,6 @@ gdictapp_DATA = $(gdictapp_in_files:.desktop.in=.desktop)
$(gdictapp_in_files): $(gdictapp_in_files:.desktop.in=.desktop.in.in)
$(AM_V_GEN)sed -e "s|\@VERSION\@|@VERSION@|" $< > $@
-@INTLTOOL_DESKTOP_RULE@
-
# dictionary sources definitions
dictsourcedir = $(datadir)/mate-dict/sources
dictsource_in_files = \
@@ -18,7 +16,9 @@ dictsource_in_files = \
thai.desktop.in \
$(NULL)
dictsource_DATA = $(dictsource_in_files:.desktop.in=.desktop)
-@INTLTOOL_DESKTOP_RULE@
+
+%.desktop: %.desktop.in
+ $(AM_V_GEN) $(MSGFMT) --desktop --template $< -d $(top_srcdir)/po -o $@
builderdir = $(datadir)/mate-dictionary
builder_DATA = \
@@ -33,15 +33,16 @@ if BUILD_GDICT_APPLET
# applet file, dbus service, and menu definition
appletdir = $(datadir)/mate-panel/applets
-applet_in_files = org.mate.DictionaryApplet.mate-panel-applet.in
-applet_DATA = $(applet_in_files:.mate-panel-applet.in=.mate-panel-applet)
+applet_in_files = org.mate.DictionaryApplet.mate-panel-applet.desktop.in
+applet_DATA = $(applet_in_files:.mate-panel-applet.desktop.in=.mate-panel-applet)
$(applet_in_files): $(applet_in_files).in Makefile
$(AM_V_GEN)sed \
-e "s|\@LIBEXECDIR\@|$(libexecdir)|" \
$< > $@
-%.mate-panel-applet: %.mate-panel-applet.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*po) ; $(INTLTOOL_MERGE) $(top_srcdir)/po $< $@ -d -u -c $(top_builddir)/po/.intltool-merge-cache
+$(applet_DATA): $(applet_in_files) Makefile
+ $(AM_V_GEN) $(MSGFMT) --desktop --keyword=Name --keyword=Description --template $< -d $(top_srcdir)/po -o $@
servicedir = $(datadir)/dbus-1/services
service_in_files = org.mate.panel.applet.DictionaryAppletFactory.service.in
@@ -56,18 +57,19 @@ ui_DATA += dictionary-applet-menu.xml
endif # BUILD_GDICT_APPLET
-@INTLTOOL_XML_RULE@
appdatadir = $(datadir)/metainfo
appdata_in_files = mate-dictionary.appdata.xml.in
appdata_DATA = $(appdata_in_files:.xml.in=.xml)
+$(appdata_DATA): $(appdata_in_files)
+ $(AM_V_GEN) $(MSGFMT) --xml --template $< -d $(top_srcdir)/po -o $@
gsettings_SCHEMAS = org.mate.dictionary.gschema.xml
@GSETTINGS_RULES@
EXTRA_DIST = \
- org.mate.DictionaryApplet.mate-panel-applet.in.in \
+ $(applet_in_files).in \
$(service_in_files) \
- mate-dictionary.desktop.in.in \
+ $(gdictapp_in_files).in \
$(dictsource_in_files) \
$(man_MANS) \
$(appdata_in_files) \
@@ -78,6 +80,7 @@ EXTRA_DIST = \
CLEANFILES = \
$(applet_DATA) \
$(applet_DATA).in \
+ $(applet_in_files) \
$(service_DATA) \
$(dictsource_DATA) \
$(gdictapp_in_files) \