summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d3f65b23..134feaa1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -99,6 +99,7 @@ GTK_REQUIRED=3.22.0
LIBMATE_PANEL_APPLET_REQUIRED=1.17.0
LIBGTOP_REQUIRED=2.12.0
LIBCANBERRA_GTK_REQUIRED=0.4
+MATE_DESKTOP_REQUIRED=1.27.1
UDISKS2_REQUIRED=1.90.0
AC_SUBST(GTK_REQUIRED)
@@ -124,6 +125,10 @@ PKG_CHECK_MODULES(GTK, gtk+-3.0 >= $GTK_REQUIRED)
AC_SUBST(GTK_CFLAGS)
AC_SUBST(GTK_LIBS)
+PKG_CHECK_MODULES(MATE_DESKTOP, mate-desktop-2.0 >= $MATE_DESKTOP_REQUIRED)
+AC_SUBST(MATE_DESKTOP_CFLAGS)
+AC_SUBST(MATE_DESKTOP_LIBS)
+
AC_ARG_ENABLE([disk-image-mounter],
[AS_HELP_STRING([--enable-disk-image-mounter=@<:@yes/no@:>@],
[Whether to build the Disk Image Mounter utility])],